Urgent advice on SketchUp/Netfabb, please

Discussion in 'Software and Applications' started by Bunrattypark, Aug 2, 2011.

  1. Bunrattypark
    Bunrattypark New Member
    What has happened to my SketchUp model?

    I have spent a month slowly working on a SketchUp model, saving regularly, and saving under a new file name after any major updates, so I have file01.skp, file02.skp, etc. and each exported to MeshLab as a 3DS, and exported to Netfabb as an STL. This worked well.

    Today, I began work on a seperate project, to be uploaded as an X3D file, with colour. That didn't work well at all, and I abandoned it.

    Now I find that my previous STL files, which had been perfectly fine up to now, will not load properly in Netfabb either. They appear corrupted, and cannot be selected for repairing or exporting. Whatever I did with the X3D file, seems to have corrupted everything else too.

    I will have lost over a month's work if I cannot rescue this. Why won't my STL files open in Netfabb properly, having been perfect up to now? Is it to do with file size, or scaling, or something else?

    Has anyone else had this trouble, and can anyone advise? any thanks.
  2. bartv
    bartv New Member
    To me, it sounds like there's a problem with your installation of Netfabb, not with your files. Did you try opening your STLs in another package, like MeshLab?

  3. Bunrattypark
    Bunrattypark New Member
    The STL files appear to open correctly in MeshLab.

    When I open them in Netfabb, they appear in green, as normal. But when I select New Analysis, they appear corrupted and broken. I am unable to select them with the cursor, and after repair, when I try to export them, the program freezes for a minute, then I get an error.

    I tried uploading one to Shapeways, and I got an overscale error, which never happened before. Similar models, the exact same size, have printed dozens of times.

    PS I uninstalled and re downloaded Netfabb...

    Last edited: Aug 2, 2011
  4. Bunrattypark
    Bunrattypark New Member
    Having spent an entire day trying to figure this out, to no end, it appears that I CAN open existing STL files, repair them, and export them as (fixed) STL files.

    However, if I change those existing files in SketchUp, even just to add one small cube, and export as 3DS to MeshLab, then as STL to Netfabb, the following happens:

    The image appears to export to Netfabb as normal, but...

    ...when a Standard Analysis is selected, this happens...

    ...and the part cannot be selected with the cursor. A repair can be applied to the part, but the part cannot be exported as a (fixed) STL, the program freezes, and after two or three minutes, a window appears, reading 'Out of Memory.'

    What now? How do I continue to export my 3D drawings as I have been normally doing for the past three months? What has gone wrong?
  5. bartv
    bartv New Member
    I'm afraid that I don't have another answer for this; have you tried on a Sketchup forum?

  6. Bunrattypark
    Bunrattypark New Member
    Hi Bart, many thanks for your feedback.

    I have spent an entire thirteen hour day on my computer trying to figure this out. It appears to be a scale issue.

    When I started uploading model buses to Shapeways, I found that I had to draw them 1,000 times fullsize, i.e. a part 10mm long would be drawn 10000mm. The resulting SketchUp files were exported to MeshLab as 3DS, and exported to Netfabb as STL. They were then analysed and repaired, and uploaded to Shapeways as (fixed) STL files. And everything seemed to work perfectly, and did so for three months or more.

    Then yesterday morning, Netfabb had canaries, and my drawing files appeared corrupted and ruined. I had no idea why, but hours later realised that Netfabb couldn't cope with models which were now exporting far, far too large. Hence they didn't appear properly on screen. By reducing the scale of the SketchUp drawings by a factor of a thousand, Netfabb would now accept them, and they could be uploaded to Shapeways again.

    But herein arose another problem. By reducing the SketchUp drawings by a thousand, numerous errors would appear. SketchUp cannot read tiny triangles below a fraction of a millimetre properly, and as a result, dozens of tiny holes would appear in the model. These were mostly repaired by Netfabb, but I found that a repaired drawing in Netfabb still appeared to have a couple of errors, marked in red, and yet I uploaded the model, errors and all, to Shapeways, and it was accepted!

    Is this model, with tiny errors, going to print correctly?

    Why do models 120,000mm long produced three months ago, export to Netfabb perfectly, and upload to Shapeways perfectly, yet similar drawings produced yesterday cannot be accepted by either Netfabb or Shapeways?

    How can I draw models 1:1 scale in SketchUp, when the tiny triangles required cannot be rendered by SketchUp, except in a larger scale? What scale do other SketchUp modellers here use?

    Or am I missing something entirely? What happened yesterday to change everything? What did I hit?

    Many thanks for any comments or suggestions.
  7. denali3ddesign
    denali3ddesign New Member
    Bunrattypark, I model in Sketchup at 1000x scale as a workaround to the missing small face issue, then scale down to the correct size to export as STL. So far, I have never had trouble with missing faces using this method.

    Have you seen this method for using Sketchup and Meshlab to make colored models?