Trouble with the Co-creator platform

Discussion in 'Bug Reporting' started by photosfromrob, Oct 28, 2009.

  1. photosfromrob
    photosfromrob New Member
    I just received a private message from a customer who had purchased a co-creator ring from my store and wanted to know how to specify the text and ring size as that wasn't available at the time of purchase.

    I checked and found that his purchase had gone through as a regular purchase. That means that he would receive the display ring....we don't want that.

    I tried to make purchases and the template didn't show up....this is a huge problem that needs to be fixed immediately.

    I had a sale yesterday and there didn't seem to be a problem, I got the info on my to-do list, made the model and uploaded it---no problem.

    Another issue:
    the Co-creator gallery has only a few models and none of mine, what's the problem there?
     
  2. arno
    arno New Member
    Hi Rob,

    I did a little research to your problem. I found out that all your co-creator models are marked as un-published.
    When a co-creator model is marked as unpublished:
    1. It is shown and sold as a regular model
    2. It is not included in the co-creator gallery

    This is exactly what you are mentioning so in that aspect the behavior is expected as the models are 'un-published'.

    Now to the reason why your are models marked as 'un-published'. There was also mail contact with Shapeways about your templates, and in your mail you wrote: "I recently changed settings on these products and that broke your system. "

    On the model details page, in the right column you can manage the model details. These are saved with [save changes] located in the bottom right of the column. The model details can be changed independent of the template details.

    In the 'manage template details' part you can change co-creator specific settings. These need to be saved with [save template details]. When the co-creator settings are saved, the co-creator template is also 'published'.

    When you want to change model details, you can do that without the need to use 'un-publish this model'. That is only needed when you want to change the template details. After changing the template details you need to use the [save template details] otherwise your model stays unpublished.

    I do not know exactly what you did change but what I suspect is:
    - You 'un-published' the template
    - Made changes but used the [save changes] in the right column instead of the [save template details] of the manage template.

    The solution to this would be to visit the model details and open the 'Manage template details' (, check the template details) and use [save template details] which will publish your templates.

    I verified all this on our test-environment and could not find irregularities in this process. If it doesn't do the trick for you, please contact Shapeways.

    Thanks, kind regards, Arno
     
    Last edited: Oct 30, 2009
  3. photosfromrob
    photosfromrob New Member
    I'm sorry you think I'm so dense that I can't tell which button to push. I triple check things before I complain...and I just rechecked before writing this reply. I press the save template button..text appears asking me to wait for the page to reload and I do. The page reloads and the template is still not published. Code is really finicky and sometimes little things can cause big problems. For some reason, the code is failing to update the database. It may be something as small a counter saying I've modified it too often....I don't know. I do know that it's a glitch in your code.
     
  4. arno
    arno New Member
    Hi,

    Didn't mean to offend you in any way ;) You'd be surprised at the questions we get here ... hehehe.

    I verified my answer by reproducing the situation and all worked well for me. Hence the most obvious that could cause the behavior was using the wrong button ;)

    We (Peter Paul and me) are investigating what is happening.

    Sorry for the inconvenience.

    Kind regards, Arno
     
    Last edited: Nov 2, 2009