Shape Ways & Sizing

Discussion in 'Software and Applications' started by Cody_Rauh, Nov 18, 2012.

  1. Cody_Rauh
    Cody_Rauh New Member
    I understand the measurements of both imperial and metric, and have worked in both frequently, recently I have been trying to upload a new product after about a year buried in university contracts. Much to my dismay all my measurements in metric imported all cattywonker, so i converted to inches, and cross checked to see appropriate sizes, and once again it important nothing as the measurements said on Blender. I tried stl and obj file imports, did a clean reinstall of blender, yet the measurements shapeways is producing from the files is nothing close even to scale as it is accurately in my 3D program.

    i uploaded a test block which is 3.5 by 4.5 inches and it came out some other weird retarded size, and I am completely confused cause i have successfully important things before without all this trouble.

    cheers,

    Perefim
     
  2. bvr
    bvr New Member
    What version of Blender are you using?
    bvr
     
  3. Mswlik
    Mswlik Active Member
    You may have not applied the scale. To do this press Ctrl + A in object mode then choose scale. This should fix the problem.
     
  4. Cody_Rauh
    Cody_Rauh New Member
    blender 2.64 & I had forgot to apply scale, but even when I do it doesn't fix it.
     
  5. Fredd
    Fredd New Member
    If you are using the scenes tab to set unit measurement, then setting the scale slider underneath for unit length measure, you will have problems with uploads unless its a dae export.
    Look at the dimensions of your object in the N panel. Select none as your option for unit measurement. If the Dimensions say 3.5 x 4.5 as in your previous test, when you upload to SW select inches. If the values there are either multiples of 2.54 or 25.4, you need to prolly upload as mm.

    Something interesting to try is that if the dimensions are like .02whatever, .023whatever, .04 whatever upload at SW as Meters. Either that or use http://www.pasteall.org/ and post the files link here . This is a site many Blender users use to share files.

    Thinking about it try uploading a .dae. file if you are using scene setting(Unit measurement thingy). It is the only Blender export that SW recognizes the scene data. So if you create a model from the outset using these measurements(If you want unit measurements in inches, for example, click Imperial, set scale(the scale thing under Imperial tab) to .0254 .If you want it in cm chose Meter, set scale at .01, in mm .001 ) Build your model remembering if you want to move it in the x 1 unit, it gets moved 1 inch,cm or mm whatever option you chose above. When done export as a .dae, its printed according to the measurements.
    Post your test file here(.obj,stl, whatever, so I can discover the problem.

    Keith
     
  6. Cody_Rauh
    Cody_Rauh New Member
    Not sure exactly what problem was but it is now working. I had tried all these things, and even had problems with .dae, but it only takes one little error to blow up the entire thing. Thank you everyone for your patience and assistance!
     
  7. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Not sure for your cube, but for the Shapeways bounding box, it's now the smallest bounding box listed, not the bounding box based on the coordinates of the upload. The software automatically finds the smallest bounding box possible to help get any density discounts possible.
     
  8. Fredd
    Fredd New Member
    Not fer the shapeways bounding box, but for the bounding box dimensions in the program while modelling. A way to chose what measurement option at upload. Besides I have always heard to keep explanations fairly simple. Besides Blender can be weird.
    Keith
     
  9. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I was just stating that comparing the numbers with software and Shapeways can lead to confusion because of that.
     
  10. Fredd
    Fredd New Member
    Lawls I know that. Several folks have sent me problems with uploads not scaling correctly. So I import it, look at the bounding box dimensions in Blender. Have to explain then why when you upload a model (Bad example again) of a cube with dimensions of .05 x .05 x .05,when you upload and set unit length at SW to meters, the cube gets printed at 5 cm *3. Then the happy camper asks why SW's bounding box dimensions does not match the one in their program. Now what you mentioned has to be explained. Volume = SW volume, no problemo. Lols. Iggy the dimension box at SW
     
  11. stannum
    stannum Well-Known Member
    Shapeways should show the size based in the original orientation. It's confusing that size changes even if all is correct in reality (no parts were removed, etc) and it was just a case of rotating the model to a better box. Imagine when it really removes parts and then rotates, all you have are the tiny renders to figure what happened.

    For owners, show the material volume and the bounding box volume that would be used in the printer, that would give the proper clues about volume discounts.
     
  12. Dotsan
    Dotsan Well-Known Member
    I agree with Stannum, the SW bounding box should be the same as the model size. I have created models to meet the maximum bounding box size for colored WSF and the dimensions on uploading are always about 5mm larger in only direction meaning my model isn't available in the colors. I could shrink the model but this changes the aesthetic and it is guess work figuring out what to shrink it by.
     
  13. bartv
    bartv New Member
    Yes, we agree that this is a confusing issue. We have made our product team aware of this and will work to get the 'real' bounding box sizes displayed on this site - not the ones that are optimized for internal use after uploading.

    Bart
     
  14. Dotsan
    Dotsan Well-Known Member
    Thanks for the reply Bart :)
     
  15. Fredd
    Fredd New Member
    I am thinking that when the geometry of the model when it is created the origin is not centered to the geometry, then the origin is not positioned at 0,0,0. So When it is uploaded the models bounding box dimensions does not match SW's. Geometry/origin gets translated to the origin at SW. It is time for SCIENCE again.
     
  16. stannum
    stannum Well-Known Member
    Bounding box is the space used by an item, it doesn't care about the origin used. Item from -2 to 2 has same size for the bounding box in that axis than from 0 to 4, or 15 to 19. Always 4 units. Absolute dimensions, unrelated to location.

    It has been already said somewhere that the issue is that the processing software rotates the item to smaller bounding box, when it founds one and with the purpose of optimizing the machine load. The obvious example is airplanes, everyone will upload them placed like a cross "+", but if rotated 30-40 degrees (it varies with each air frame and wings) so they look like a "x", they have a smaller bounding box.
     
  17. Fredd
    Fredd New Member
    Yea, I figured that out with the failed experiment. So as long as volume is the same, I will try to forget about it lol.

    Keith