Little help needed

Discussion in 'Design and Modeling' started by Jettuh, Jan 10, 2011.

  1. Jettuh
    Jettuh Well-Known Member
    Hi all,

    I've been having some issues lately with uploading.
    since 2months several models of mine won't shop up in my shop how to have to be.
    Some parts of the model are missing.

    i know this could be because of the shells - when using 3ds max,, you will always have shells,,, using union screws your model when having more then 1000poly :S -
    but before i never had problems with shells,, and shapeways accepted it,, and showed it perfectly.

    http://www.shapeways.com/model/199089/1snel.html?gid=ug16518
    as you can see on the model,, some seats are gone....
    but if you check the file in the attachment,, you see there are several more seats then in the model that is uploaded (same file)

    Can somebody check my file and see how I or we can fix this?

    thanx in advance
     

    Attached Files:

  2. virtox
    virtox Active Member Moderator
    Not sure, but it might just be some volumes are inside out?

    The 3d view fails for me on this object, so I can't see what happened to it on the server.

    I did see another topic where someone had multiple shells whereby some were cut out instead of added.

    Anyway, if that is it, Max has a tendency to flip the normals of an object when using mirror or negative scaling.

    Which max version do you use?
    You could try the Shapeways Maxscript I wrote. It has an option to detect negative volumes.
    (no option to fix them though, if need be I could whip something up ;)

    Cheers,

    Stijn
     
  3. Jettuh
    Jettuh Well-Known Member
    Stijn,

    thanc for trying to help, but no luck i'm afraid!

    normals aren't a problem for me!
    when object is flipped,, i press the "reset xform" and then i can see wich objects are flipped,, by selecting the model then, i can flip normals!
    so everything is in the same direction!


    Does somebody know what to do?

    thanx in advance
    Mitchell
     
  4. Kaetemi
    Kaetemi New Member
    You've got overlapping faces, probably caused by a symmetry going wrong, resulting in pieces being merged with broken geometry and thus consequentially getting trashed away.
     
  5. Jettuh
    Jettuh Well-Known Member
    Kaetemi,

    but why is this happening to some of the seats,, and not all?
    cause all of the seats are the same?
     
  6. Kaetemi
    Kaetemi New Member
    Apparently they're not...

    [​IMG]
     
  7. aeron203
    aeron203 New Member
    One thing I notice about your model is that the left and right edges of the adjacent seats are right on top of each other. That's always asking for trouble, but I don't think it would make random ones disappear. It does sound like a bad transform/mirror but if you've already looked at that I'd send them separate from the car and see if the error still occurs.

    I also noticed you model is (fixed) with Netfabb? I tried using Netfabb for awhile because I know Shapeways uses it, so I thought it would be more compatible, but I notice it often breaks complex models that uploaded fine before! Errors like the first one I described with coincident faces can become even worse when Netfabb tries to join everything together. It makes a mess that will confuse MeshMedic.

    Try making the components work first before you combine everything.

     
  8. Kaetemi
    Kaetemi New Member
  9. Jettuh
    Jettuh Well-Known Member
    Ok, thanx!

    i'm going to try fixing the overlapping stuff!
    i hoped netfabb would have solved those issues for me!

    I allready got the plate below the seats to have none overlapping faces!
    now the seats!

    Kaetemi, which program do you use?

    Mitchell
     
  10. Kaetemi
    Kaetemi New Member
    It's the xView feature that's built into 3ds Max 2010.

    Parallel overlap is somewhat difficult to process, because floating point inaccuracies will lead to undefined states.

    Two parallel overlapping faces that share an edge might be a possible cause, as this would create an undefined state where the resulting zero-volume volume where the faces overlap is neither correctly oriented nor inverted, nor does it have a slicing line for the planes, nor does it connect two meshes to each other.
    Or maybe something else, but overlapping parallel planes are never a good idea. =)

    As easily demonstrated by 3dsMax's ProBoolean:
    [​IMG]

    (Netfabb fixes the above issues though...)
     
    Last edited: Jan 11, 2011
  11. Jettuh
    Jettuh Well-Known Member
    thanx Kaetemi!

    tried to weld the vertics that were shown by xView!
    now i think i've found the problem!

    My model is made 1:1..... so the points are not that close to eachother... xView says only 34 vertics are overlapping..

    now the problem is (what i think) is that i scale my model down to 1:160!
    this way all vertics will be scaled down, and if the tolerance isn't high enough, mesh medic would think they overlapse eachother

    could that be the thing?

    edit: this is the stl file before being scaled down and before netfabb fix
     
    Last edited: Jan 11, 2011
  12. Kaetemi
    Kaetemi New Member
    Which program and file format do you use for downscaling?
     
  13. Jettuh
    Jettuh Well-Known Member
    STL, by using netfabb!
    when i did in 3ds max,,, there was even less model when uploaded to shapeways!
     
  14. Kaetemi
    Kaetemi New Member
    Okay, here's a trick:
    - Open stl in MeshLab (hit ok on a warning)
    - Save as x3d (remove the normal checkboxes)
    - Scale 0.00625 (it's hidden in some menu that says normals, curvature etc)
    - Save
    - Open x3d in netfabb
    - Save as stl binary
    - ???
    - Profit!

    3dsmax and netfabb are bad at heavy scaling operations...
    MeshLab probably does some sanity checks while scaling. Saving as x3d also seems to have higher precision. Netfabb is particularly good at properly saving as STL. And don't go for uploading directly as X3D in this case, because then you'd have to scale it down even further to meter units.
     

    Attached Files:

    Last edited: Jan 11, 2011
  15. Jettuh
    Jettuh Well-Known Member
    I'm trying your way now.
    but i can't save in x3d? says can't load libxiot.dll
    so trying trough 3ds max now.

    your scaling in 0.00625 , i'm scaling in 0.00627 haha

    but your uploaded file works :eek: wtf your amazing!
    gonna try it now myself using the 0.00627

    thanx a lot


    edit: got x3d working,, was having an old version of nettfab!
    edit: read it wrong,, you said meshlab! gosh long time ago i used meshlab haha
     
    Last edited: Jan 11, 2011
  16. Jettuh
    Jettuh Well-Known Member
    Kaetemi,

    when i scale it in meshlab,, and open it then in netfabb,, it says it's like 100x as big as the 1:1 scale?

    when uploaded:
    The size is 2570820.10 x 1384423.15 x 132544.11 cm / 1012133.90 x 545048.48 x 52182.72 inch.

    oftewel, veelste groot?
    ik heb precies zoals je zei gedaan in meshlab?
    save x3d,,, scale 0.00627 save xd3
    en als ik hem dan in netfabb open is hij ineens heeel groot ipv heeeel klein?
     
    Last edited: Jan 11, 2011
  17. Kaetemi
    Kaetemi New Member
    [​IMG]

    en mm selecteren bij het uploaden? :)
     
    Last edited: Jan 11, 2011
  18. Jettuh
    Jettuh Well-Known Member
    Nu wordt ik helemaal gek!

    Heel erg bedankt Kaetemi voor de plaatjes!
    maar geloof het of niet! ik krijg
    kaetemi.JPG

    ik zie wel dat je "freeze Matrix" bij scale heb aanstaan, ik heb heel dat icoontje niet!
    eens ff nieuwe versie van meshlab downloaden!

    misschien dat het daaraan ligt :confused
     
  19. Kaetemi
    Kaetemi New Member
    Ik heb
    MeshLab 1.3.0b en netfabb 4.5.0
     
  20. Jettuh
    Jettuh Well-Known Member
    hmmm die heb ik ook!
    heb je nog bepaalde settings aangepast @ meshlab of netfabb?