Feedback.shapeways.com: 'single signon' activated

Discussion in 'Official Announcements' started by bartv, Dec 22, 2011.

  1. bartv
    bartv New Member
    Hi,

    we've just integrated Uservoice (our community feedback tool) more with the rest of the website: your regular shapeways.com login now also works on Uservoice.

    For new users, it'll just work. For existing users, it will create a new UserVoice account for you (nothing I can do about that, sorry!). This is a bit inconvenient as your existing issues will no longer all show up onder 'my feedback'. On a positive note: you all get a fresh set of votes to use!

    In case you're wondering what I'm talking about:

    You can find more information about UserVoice here, or just try it out on feedback.shapeways.com.

    Also, we're GREATLY appreciating all the feedback that we're getting on Uservoice, and we're doing our best to address the most 'popular' (or hated ;) tickets ASAP. Things are a bit busy for development during the last weeks of the year, but as of January you should see a big increase in the number of tickets that we're closing.

    Happy holidays!

    Bart
     
    Last edited: Dec 22, 2011
  2. mctrivia
    mctrivia New Member
    thanks. so now we can't log in to user voice at all.
     
  3. ana_xyz
    ana_xyz New Member
    mctrivia, please refrain from the highly negative tone. That'll help us get it fixed faster.

    What are the details on the issue?



     
  4. mctrivia
    mctrivia New Member
    well i thought instead of being negative and saying

    "come on guys. you can't even do such simple testing as log out, log in and try to get on user voice. this is rediculous."

    I thought I would just thank you for the new feature. "Impossible to use uservoice". Seriously was not being sarcastic.

    as for symptoms. can't log in to user voice. clicking login results in new window saying I am loged in but reloading old window still says loged out of user voice.

    you really nead to get test server up before you make any changes. you have proven over and over your staff don't know how to test. I know you won't listen to me but maybe you will listen to others. People if they ever fix user voice please vote on: http://feedback.shapeways.com/forums/111989-shapeways-feedba ck/suggestions/2457232-test-site
     
    Last edited: Dec 22, 2011
  5. ana_xyz
    ana_xyz New Member
    Yep, preventing you from using Uservoice was totally the plan all along. :p

    Thanks! How about browser info?

     
    Last edited: Dec 22, 2011
  6. stop4stuff
    stop4stuff Well-Known Member
    I'm getting a similar issue :(

    Win XP & IE8.0

    Here's a couple of screenshots.

    uservoice03.JPG

    Paul
     
  7. aegidian
    aegidian New Member
    Looks like you're using a CSS style-sheet or template stored in the restricted area of shapeways.com, change that and it'll be fixed.

    @ana Criticising a disgruntled user's tone when you have problems is not helpful, it simply increases the degree of antagonism. Meet strong criticism with an example of the politeness you'd like to inculcate instead.
     
  8. bartv
    bartv New Member
    There seem to be two issues here:

    - Access restriction on the CSS: this was caused by a server migration earlier today - this has been fixed.

    - Not being able to log in: I can confirm that this is now broken. This is odd, because I personally ran several test scenarios for this yesterday and it worked fine.

    I'm switching single sign-on off for the moment and I'm handing this back to development.

    Sorry for the trouble. With the Holidays coming up, I expect this may not be fixed until the first week of the new year.

    Bart
     
  9. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Good morning everyone :). Having a good week?
    I am able to log in this morning. Has anyone else tried again?
     
  10. stop4stuff
    stop4stuff Well-Known Member
    Mike, you got lag... it's PM this side of the pond ;)
    Looks like the fix was in place before you woke up :laughing:

    [edit] Yep ability to login now works again.

     
    Last edited: Dec 23, 2011
  11. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    In that case
    Truman: Good morning, and in case I don't see ya, good afternoon, good evening, and good night!
     
  12. ana_xyz
    ana_xyz New Member
    Bart, thanks for the update and the temporary fix.

    Paul and Mike, thanks for confirming that Uservoice works again!

    @aegidian I'm being playful, giving mctrivia a wink and a nod to remind him that we're all on the same page, while at the same time working to get this fixed as quick as possible. Sorry if it came across as insensitive. So many nuances get lost in these digital conversations.

     
  13. ana_xyz
    ana_xyz New Member
    Hey all, an update on this:

    Since this problem surfaced late in December, I've had members of my team working on a long-term fix. We've confirmed we were actually facing bugs with Uservoice, which despite lots of detective work, we haven't been able to recreate.

    Tomorrow we're going to turn single signon back on at 9am EST. I will be watching how things go closely, and I have my team on standby. What I could use from you guys on this thread is eyes and ears. If you or another member of the community comes across an issue with the feedback.shapeways.com login process, please either alert me here or shoot me an email at ana@shapeways.com so I can handle it immediately.

    While this is more experimental and less foolproof than waiting for a definite answer, if we pull together and keep eyes and ears open, it'll ultimately help us move forward faster.

    Thanks in advance. :)