color print, preview is showing wrong mapping

Discussion in 'General Discussion' started by celso, Feb 12, 2013.

  1. celso
    celso New Member
    Hello!

    I am trying to get this model printed.
    It was hard to get the file to shapeways without getting errors.
    Know the file is finally there but the texture on the preview model looks wrong.
    At firs I was thinking the uvs got flipped some how, the original file was created in zbrush and it always flips the uvs.
    But it does not appear to be the case, I flipped the texture in every way possible and the preview still showing wrong.

    The textures are showing fine inside meshlab and zbrush. and has to be flipped in both axis to display right in 3d studio max.

    How should I proceed ?

    Thanks
    Celso
     

    Attached Files:

  2. celso
    celso New Member
    Here is a print-screen showing what i mean
     

    Attached Files:

  3. stop4stuff
    stop4stuff Well-Known Member
    tandard analysis in NetFabb shows there are 11 shells that make up the model - eg, there's one seperate shell in the left hand that's not connected to anything. The disconected shells* that are within a solid shape are removed by Shapeways MeshMedic when the model is processed at upload time. Removal of the shells causes the UV mapping to go awry.

    *By disconnected, I mean disconnected from the 'outside world'. Hollow space needs a connection otherwise it is just a void that gets filled.

    Paul
    [hr][hr]

     
  4. celso
    celso New Member
    Thanks a lot for helping Paul.
    I usually use netfabb for fixing the model, but was loosing the uvs true it.
    But believe or not the solution for my problem was way simpler than i thought.

    I just had to uncheck the Color option when exporting and worked just fine!

    Thanks again

    Celso
     

    Attached Files:

  5. robertbonenfant
    robertbonenfant New Member
    Cel -
    How did you fix it - Im trying to print my Wow Guy
    It looks perfect in 3Ds Max but in ShapeWay the whole texture is way off
    Face is down near the legs
    Any Advise ??
     
  6. lensman
    lensman Well-Known Member
    I don't have ZBrush in front of me at the moment so I'll try and answer that for you... When using the plug-in 3D print Exporter there is a button for "Advanced" options. Click it and a whole bunch of other buttons unroll below. There is one titled "Colors". Click on it to turn it off...

    Having said that whenever I've had this problem I'm pretty sure that didn't solve it. Maybe I never tried that. I've always had to load the ZBrush texture file into a painting programme and flip it (left to right) before putting it into the ZIP file.

    Oh, and another thing, the JPG that ZBrush exported (in newer versions) saves the files as JPEG which doesn't seem to be recognised by Shapeways, so I always export it now as a PNG.

    Let me know how you get on.

    Glenn
     
    Last edited: Apr 15, 2013
  7. celso
    celso New Member
    Sorry for the waiting,

    For me the problem is i was loosing all the uvs when trying to fix the model on netfabb

    For printing on color you must export the file as WRL

    to keep the uvs in place and fix some small problems you have to use meshlab instead of netfabb.

    and if you are using zbrush you must convert the jpeg to jpg, and after you do you have to oppen the wrl file on a text editor and change the jpeg to jpg there too.

    if the model have some small problems shapeways uploader will probably fix it on the go and keep the uvs.

    Hope this helps,

    Thanks
    celso
     
  8. celso
    celso New Member
    and remember to flag off the color option on mesh lab when exporting, it will conflict with the uvw