Can't find Manifold Error

Discussion in 'Design and Modeling' started by gyoenastaader, Feb 20, 2010.

  1. gyoenastaader
    gyoenastaader New Member
    I've used MeshLab and Blender, and neither can find the error the Shapeways checker is finding.
     

    Attached Files:

  2. GHP
    GHP New Member
    When I tried the "Remove Non-Manifold Faces" function in Meshlab, it found and removed 88 faces, after which the model was apparently manifold and free of holes. (I also had it remove duplicate vertices when opening the file.) I'm attaching the result.

    Blender thought it was manifold after the removal of duplicate vertices. Blender typically removes "duplicate" vertices that Meshlab does not think are duplicates, so this may be the reason for the difference. (Although my past experience has been that Shapeways is more likely to agree with Blender than Meshlab on this.)
     

    Attached Files:

  3. aoster
    aoster New Member
    Hi,
    I attached to model in a way that uploads fine to Shapeways.

    Bye,
    Alex
     

    Attached Files:

  4. gyoenastaader
    gyoenastaader New Member
    Thanks! Strange that Meshlab found it for you, it always reported zero for me.
     
  5. dymihail
    dymihail New Member
    Did you try both "Non-manifold faces" and "Non-manifold vertices?" I've found that the removal of one will introduce the other, such that the other filter needs to be run again. I've also found that re-running the filter can crash the system. And that after saving, I can get more errors if I re-run either filter yet again. And sometimes it will find the same error that it claimed it had just fixed

    Basically, my experience with MeshLab has been that it has some interesting features, but that it's buggy, unreliable, inconsistent and prone to crashes.