YouTube Videos on our shop ! - Good job !

Discussion in 'Shapeways Shops' started by dizingof, Jul 14, 2010.

  1. dizingof
    dizingof New Member
    Check out my shop, almost all items have videos - hope this will bring some "Yeppeee" emails as a result ... :rolleyes:


    2 errors found:

    1. when there is a space at the end of the line it wont accept the youtube URL.

    2. probably a parsing issue - these URLs are'nt accepted :
    http://www.youtube.com/watch?v=Km-RvuJ_s7A
    http://www.youtube.com/watch?v=QMixHEznh-Y
    http://www.youtube.com/watch?v=-rd5SQeaD5U

    (my guess the dash - ?)

    BTW, shapeways server is acting real slow for me , ping is OK but the lag is sometimes annoying.

    FYI... From a point of view of a visitor - a page which is slow to download for over 5-8 seconds - you lost that visitor ..
    Also... Google has recently adjusted it's algorithm to downgrade slow websites... :confused


    Cheers,

    Dizingof
     
    Last edited: Jul 14, 2010
  2. jdl
    jdl New Member
    Hi Dizingof,
    thanks for your feedback, I have made sure it was passed on to our tech guys
    Jo
     
  3. rawkstar320
    rawkstar320 New Member
    Love the video feature, now i have to make videos...


    And i want to "bump" the mention of shapeways being slow. I realize that uploading a file takes a while...but lately it has been taking forever. I have a strong feeling that most of it is on my internet connection end, but everyonce and while I think Shapeways contributes to the slowness.


    :)
     
  4. bartv
    bartv New Member
    Hey rawkstar,

    did you know you can 'zip' any file before uploading them? (Including STL) I'm on a rather slow connection myself and this saves me a lot of time.

    Cheers,

    Bart
     
  5. jeff
    jeff New Member
  6. Tommy_2Tall
    Tommy_2Tall New Member
    Hi!

    If the parsing-problem dizingof highlighted is still present my guess is that it only allows "http://" followed by alphanumerical characters (a-z,0-9) and forwardslashes, dots and questionmark(s).
    Try getting rid of the "&sns=em" part of the URL.
    I don't know what the "sns" parameter controls but I couldn't see any difference in the resulting page.

    For the techies, this is the actual regular expression used to match the URL's:
    Code:
    /^http:\/\/www\.youtube\.[a-z]+\/[a-z\?\&\#!]*v[/|=]([-a-zA-Z0-9_-]+)$/m
    Cheers!
     
    Last edited: Aug 18, 2010
  7. dizingof
    dizingof New Member
    on that note.. i want to add that if you have a url like the ones i posted on top, with a dash and you want to edit the product's picture, price etc by hitting the SAVE button.. you'll get an error saying the youtube url has an error - though this bug was already fixed...

    a work around for now is to remove the youtube url. save. then edit your product , hit save THEN add the youtube url and save.


    Cheers
    Dizingof
     
  8. jeff
    jeff New Member
    Thanks you guys. Saved and retried w/ the last bit removed and the link worked. I was doing this on my iPad, so maybe the last bit was for a mobile version of YouTube? You guys know more then me on this stuff, so thanks for the help.