"Your model was too small for any of our 3D Printers" -- any way to get more debugging inf

Discussion in 'Technologies and Hardware' started by dcltdw, Oct 10, 2012.

  1. dcltdw
    dcltdw New Member
    Hello! First-time user with a probably foolish question. :)

    I created a very simple model (see attachment) that's 3" in diameter and 0.354" tall. When I upload it, I get the (emailed) error:

    > Your model was too small for any of our 3D Printers.
    > Our printers have a minimum bounding box size (h x w x d) of 0.25 x 0.25 x 0.25 cm / 0.098 x 0.098 x 0.098 inches.

    I'm wondering what I'm doing wrong. :)

    One caveat is that I created this is Sketchup 8 and then exported it into DAE format, so I don't actually know what it looks like in a DAE viewer.

    I'd be very grateful for any help. Thanks in advance!

    Attached Files:

  2. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    The email should also tell you the size of your upload. I'm pretty sure your problem is units. Which units did you select at upload? I'm assuming inches? Try mm.
  3. dcltdw
    dcltdw New Member
    No, the email message didn't say anything about the size of the model.

    Also, I don't see any option to specify units during upload. I just get what file to upload and a title. Should I be using something other than http://www.shapeways.com/upload/ to upload a file?
  4. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
  5. mkroeker
    mkroeker Well-Known Member
    The header of this DAE file contains the line
    <unit meter="0.02539999969303608" name="inch" />
    and aunt google tells me that recent versions of sketchup
    appear to default to inches, whereas it used to be possible
    to choose the base unit on export.
    Perhaps the import software at shapeways tries to be helpful
    and applies the scaling factor from the units line in unexpected
    ways ?
  6. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Are you sure it has thickness? I just opened in meshlab and it's just a flat surface.
  7. dcltdw
    dcltdw New Member
    Yes, it has thickness of 0.354". When I open it in Meshlab, I can see that it has thickness. (I've never used Meshlab before, so I'm not sure how to measure lengths.)
  8. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Ah ok, What I was seeing is that your file includes the sketchup guy. I'm thinking he may be the issue.
  9. dcltdw
    dcltdw New Member
    Fascinating. I'll try re-uploading.

    FWIW, I just tried to upload a version where everything is blown up 10x in Sketchup: so 15" radius, not 1.5" radius. That succeeded, but Shapeways is reporting the model's size at

    cm: 0.3 w x 0.036 d x 0.3 h
    in: 0.1 w x 0 d x 0.1 h

    I switched templates in SU to be feet/inches (interior).
  10. dcltdw
    dcltdw New Member
    Btw, I tried uploading the DAE without that line -- no dice, alas.
  11. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I deleted the man in Meshlab and it uploaded to your specified dimensions (showing up as 3x3x.4 inches)

    Attached Files:

  12. dcltdw
    dcltdw New Member
    Likewise. If I may make a suggestion: that's something that should be noted in the pages that talk about SU. :)

    Thanks muchly for your help!
  13. Fredd
    Fredd New Member
    I pulled the file up in blender. Each dimension in sketchups Dae according to blender was mm.354 x 3 x3. . So the DAE possibly might have scaled a Sketch up unit to a mm. I am guessing SU's basic unit of measurement might be a mm. Try it with a stl model imported to nettfab. Check the dimensions. Net fabbs dimensions usually agrees with SWs.
    So if you want your basic unit in Sketchup to be regarded as an inch, when you browse your file to upload to SW, change the bottom selection to inch. It would not have mattered anyway, the model needed doubles removed, some face normals flipped, and two verts merged. Easy to fix

    As for a test. create a 1 x 1 x1 cube in sketch up, export as a STL, then check dimensions in Netfabb. Or just PM me the file, lol.
    Last edited: Oct 11, 2012
  14. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I'm no Blender expert, but I'm fairly sure Blender units are what ever you specify them as. See the OP checked the file, and we were able to upload successfully, we know the units are inches.
    STL also doesn't specify units. So a 1x1x1 cube is exactly that. When you upload, you select the units, so the 1x1x1 cube can be mm, inches, or meters.
  15. Fredd
    Fredd New Member
    Thanks for posting the DAE first. Was fun to work in that format, except for the ugly gal. And great thanks to Youknowho. I have been only exporting in STL, which setting unit measurements doesn't work. It finally sank into my thick skull when I uploaded the pendant. Setting unit measurement does effect when you upload other formats, besides STL and VMRL(??). Thanks again. I am off to kick myself in the rear several times for being stupid.
  16. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I believe VRML defaults to meters. I know for STL and OBJ you have to specify the intended units when uploading to Shapeways.