Yet another topic on manifold errors

Discussion in 'Design and Modeling' started by Charmed_Life_Designs, Feb 27, 2010.

  1. I'm sure you all are tired of the newbies coming for help with manifold errors, but... I've been struggling with these necklaces for hours. I keep getting manifold errors when I try to upload them, but I can't seem to locate where the error is coming from. Neither Blender, Meshlab, nor Shapeways' model error analysis have been able to find a manifold error, but I keep getting the "non manifold mesh" message when I try to upload. I've remade the models a few times and double checked everything, but no dice.

    It's a little embarrassing, since these are simple models and I consider myself to be a relatively clean modeler. Could you help please?

    Knowing my luck, it'll have been something really silly and obvious that I missed...
     

    Attached Files:

  2. GHP
    GHP New Member
    I had a look at note.x3d. Unless you want to do these in the color sandstone, I would suggest using the STL format with millimetres for your units. The X3D and VRML formats tend to have very small numbers (since the units are metres), and Shapeways regards very close vertices as duplicates (unlike Meshlab, which is more precise). Otherwise, you might try redoing your model with fewer vertices for the loop and areas where it joins the note, since this was very dense in some places.

    As you say, your model (note.x3d) checked as manifold in Meshlab. In Blender, it wasn't manifold after the removal of duplicate vertices (with the limit set to zero). (I wasn't able to open the X3D file in Blender, but I saved it from Meshlab as a PLY file and imported it into Blender as that.) Meshlab seems to be more precise than Blender or Shapeways in identifying different vertex positions, especially with very small numbers.
     
  3. Eeppium
    Eeppium New Member
    i´ve had a similar problem with my recent model. it has a base structure with few intersecting (separate) parts and it gives the manifold error also.
    meshlab and blender can´t find anything wrong with them also.
    i also tried to upload an older model, with similar properties wich has worked fine before, but now it won´t.

    I have sent email to shapeways about it.
    hopeully the problem is going to be solved soon.
     
    Last edited: Feb 28, 2010
  4. aoster
    aoster New Member

    Attached Files:

    Last edited: Feb 28, 2010
  5. Thank you for your help! Your input and tweaking of my models helped me to get them printable, and I learned what to do in the future to avoid these problems. Modeling for 3d printing is very different than what I'm used to, so thank you for helping this "newbie" out. It's much appreciated. :D