WRL File not working

Discussion in 'Software and Applications' started by hishamha, May 25, 2013.

  1. hishamha
    hishamha New Member

    I tried uploading a colored VRML file that I created in Solidworks. It seemed to upload fine, but I soon received an email saying that the file failed to upload. I contacted support asking for help, and they said my texture was missing, and that I should come to the forums for help. Here I am.

    I've attached the file that wouldn't upload. I'd really appreciate any help I can get with this.


    Attached Files:

  2. mkroeker
    mkroeker Well-Known Member
    Missing texture file may be the most common error, but in this case you are using vertex colors, no separate texture file needed,
    so the default suggestion given by service does not apply.
    The real problem is that your wrl file is written in the "ancient" VRML1 format instead of the VRML2 (aka VRML97) required by
    shapeways - the first line of the file already gives it away "#VRML V1.0 ascii" instead of "#VRML V2.0 utf8".
  3. mkroeker
    mkroeker Well-Known Member
    See here (help.solidworks.com) for available vrml export options - you will definitely need to set version to 2 , probably play with the quality to get less visible facetting of polygons, possibly change the coordinate system if the default view in shapeways is sideways or upside-down (though that does not matter for printing)
  4. hishamha
    hishamha New Member
    Thanks a lot for your reply. Do you know of any way I can convert from VRML 1.0 to VRML 2.0?
  5. mkroeker
    mkroeker Well-Known Member
    The transition from vrml1 to vrml2 happened in the late 1990s, so most software will probably have dropped off the web by now.
    This page contains a link to what is probably a copy of the vrm1tovrml2.exe that used to come with the long-gone cosmoplayer viewer. (No idea if it is legit wrt. copyright and possible viruses, but at least it is hosted on the group webpage of a Florida State University professor) .
    If it is just this single file, you could also try to do the conversion by hand in a text editor - for the most part, VRML2 is just a much
    more verbose presentation of the same information. If you still have access to SolidWorks and the original SWX file, re-exporting
    as VRML2 is obviously the best choice.
  6. hishamha
    hishamha New Member
    When I try to save it as VRML2 I get the error message:

    "The current document is empty. No VRML file will be generated."

    Any ideas?
  7. stonysmith
    stonysmith Well-Known Member Moderator
    Try this copy.

    Attached Files:

  8. hishamha
    hishamha New Member
    It worked! Thank you so much.

    Would you mind telling me what you did in case I need to do it in the future?