Work in progress: 'Solving Shapeways Upload Issues'

Discussion in 'General Discussion' started by bartv, Aug 14, 2008.

Thread Status:
Not open for further replies.
  1. bartv
    bartv New Member
    Hi,

    I've been writing down common problems and fixes that we encounter at service@shapeways.com. They have all been collected and written down in 'solving upload issues'.

    If you have any new hints that you think should be included, please leave a comment!

    Cheers,

    Bart
     
    Last edited by a moderator: Dec 27, 2013
  2. Christel
    Christel New Member
    Under error message ""The model could not be validated." it says "this error message is b0rked"
    Keep in mind that not all users will understand hax0r jargon ;)

    Under "Fixing your file" pt. 3, it says: "Make sure the mesh is completely non-manifold"
    I'm not sure that's really what you mean to say ;)

    Otherwise very helpful :)


     
    Last edited: Aug 15, 2008
  3. bartv
    bartv New Member
    Thanks Christel! I got a bit carried away there ;) My remark about 'non-manifold' was wrong - it should've been 'manifold'. I wish we could drop that term all together and replace it with 'watertight' but I don't think that's mathematically correct...

    Cheers,

    Bart
     
  4. KoalaCreek
    KoalaCreek New Member
    Bart,
    As you are aware, I experienced quite some upload issues. I design my models in Alibre Design Xpress and export them to STL format.

    For thoise who use the STL format, I seem to have found a way to solve the issues by using MiniMagics.

    I just import the STL file into MiniMagics and then save them again as an STL file (with a different filename ...). It looks like it does the trick and it also compresses the STL file.
    Had one which went from 11MB down to 2 MB.

    Maybe it's something to add to the Google Docs doc.

    Cheers,

    Jeroen


     
  5. bartv
    bartv New Member
    Thanks Jeroen!

    I've just added your suggestion to the doc. I used MeshLab for the job (free, open source).

    Cheers,

    Bart
     
    Last edited: Aug 19, 2008
  6. madox
    madox New Member
    Thanks for the MeshLab recommendation, it is indeed free and open source with a pretty nice interface.

    Infact it recommended the recommended changes upon opening the part and all you need to do is a 'Save As'.

    (Also use Alibre Xpress and ran into the same problem)
     
  7. protobernd
    protobernd New Member
    Hi folks,

    now that I was going to post my clews on Alibre Design STL-files and shapeways uploads, I find that I should have read more in this forum before.

    In fact, I found that Alibre Design exports too many vertices to the STL format. Now, MiniMagics did not tell me about such duplicate vertices which is why I got the message saying my design was non-manifold. Yet, MeshLab did tell me and by clearing "duplicate vertices" the file size was not only tremendously reduced, even better: it is accepted by shapeways.

    By the way, I am quite excited about my first print and I appreciate the ease of use while uploading and ordering models from the shapeways website.

    Cheers,
    Bernd
     
  8. pete
    pete Shapeways Employee CEO & Co-Founder
    Hey Protobernd,

    would you like to document your findings with Alibre Design and Shapeways? A step by step guide could be really useful (with some screenshots) so we can add it to our tutorial section.

    This could help other Alibre users.

    Just asking :)
    regards,
    Peter
     
  9. madox
    madox New Member
    We're sorry, but there was a problem with processing your model 'Mechanical
    Iris - Single Assembly'. It didn't pass the checks that
    we run to make sure a model is printable. Here's the error message:

    The model could not be validated.

    This means that we had problems recognizing your file. We have a tutorial
    that explains how you can
    solve this issue on the site. You could also ask for help on our forum.

    :(
    Admittedly its a rather large (30Mb) STL file, is that error just simply saying the validation process timed out or crashed? I'll try a more coarse STL file later...

    On that note, have you guys considered accept gz'ed or zip'ed STL/X3D files? It reduces the transfer size alot.

    Reducing the detail in the STL worked...<SIGH>
     
    Last edited: Dec 3, 2008
  10. bartv
    bartv New Member
    Hi Madox,

    the filesize is not the problem, please have a look at the page 'solving upload issues' that we're linking to above and scroll down to ""The model could not be validated.". A possible solution is described there.

    If that doesn't fix it, please contact service@shapeways.com.

    Cheers,

    Bart
     
  11. madox
    madox New Member
    Hi Bart,

    I also used Alibre Xpress and was tweaking the STL export options like the other people above.

    The failed file had a max triangle plate size of 0.1, since adjusting this value to max larger plate size of 0.2 the STL validated with Shapeways and is available for printing.

    I'll write up a short tutorial on how to export from Alibre to Shapeways later today if you're still interested.

    Documented my pain and suffering in this blog post...
     
  12. madox
    madox New Member
  13. Baalrog
    Baalrog New Member
    99% of my errors are nonmanifold, and they happen quite often

    The meshes are manifold when checked in maya and meshlab, but something happens once it's uploaded...maybe a further vert weld that mangles the manifold polies.

    The error viewer used to do something, but the camera was always placed in the center of the model and there wasnt anything to see except an occasional red line...without a mesh to see it was kindof useless. I havent seen any red lines in that viewer in the last few weeks.
     
  14. bartv
    bartv New Member
    Hi Baalrog,

    I'd be very interested in seeing some of those files that are validated as manifold by Maya and/or Meshlab but then fail our test. Could you mail them to bart@shapeways.com?

    Thanks!

    Bart
     
  15. photosfromrob
    photosfromrob New Member
    I have two issues...
    1. I've had a model rejected as non-manifold---Meshlab, Rhino and Magics OKed the model AND I uploaded a smaller version (just scaled down) that was OKed. I think you have a fault in your software.
    2. I had a model similarly rejected last month...I sent a copy of the model in an email to service @ shapeways like suggested, that was Sept 25. I have still not been told what your results were.
     
  16. RalphVdB
    RalphVdB Well-Known Member CS Team
    Hi photosfromrob,

    please sent your file to ralph@shapeways.com and i will look into it for you.
     
  17. RalphVdB
    RalphVdB Well-Known Member CS Team
    Hi,

    i took a look at your model. Nothing is wrong with it. If you upload in mm, it will pload just fine! Good luck!
     

    Attached Files:

  18. photosfromrob
    photosfromrob New Member
    OK...now it uploads. You still have not addressed my
    question. WHY WAS IT REJECTED TWICE FOR MANIFOLD ERROR ? Is there a problem with your software...did you even check. It was rejected TWICE and then accepted with on changes. I've had this happen before.
     
  19. ggunhouse
    ggunhouse New Member
    I'm having the same problem. Meshlab says the model's OK, Shapeways rejects it for being non-manifold. The Shapeways error viewer shows nothing (no red lines, no visible model).
    I have uploaded it many times. I guess if there's a chance it will eventually be accepted, I'll just keep trying.
     
    Last edited: Oct 21, 2009
  20. joris
    joris New Member
    email it to service (at) shapeways (dot) com and we'll have a look at them.
     
Thread Status:
Not open for further replies.