Why does it take now hours to verify a model?

Discussion in 'Shapeways Shops' started by Oskar_van_Deventer, Jul 21, 2010.

  1. Oskar_van_Deventer
    Oskar_van_Deventer Well-Known Member
    Hi Shapeways,

    As you know, I have uploaded many models. Typically, it takes a minute or two to get it visible in my shop after the model is uploaded. Now it is taking many hours. I uploaded some models around 18:30. Now it is nearly 22:00, and still no confirmation or error message.

    Also, your upload system recently rejected a perfectly fine .stl file, claiming a non-manifold problem. Meshlab says the file is fine. I can see that the file is fine.

    What is going on?

    Oskar
     
  2. pete
    pete Shapeways Employee CEO & Co-Founder
    Hi Oskar,

    we will have a look tomorrow, meanwhile our site has been very busy today and also we have been getting many more uploads so this could explain the delay (somewhat).

    Regarding the disqualifying of your fine model, that is for Arno and crew to have a look at.

    Peter
     
  3. robert
    robert New Member
    Hey Oskar,

    That is odd. We will look into it.

    Could you please send your file to service[AT]shapeways[DOT]com so we can take a look at your rejected STL?

    Thanks!

    Robert
     
  4. Oskar_van_Deventer
    Oskar_van_Deventer Well-Known Member
    > Could you please send your file to service[AT]shapeways[DOT]com so we can take a look at your rejected STL?
    Thank you, I had already done so.

    I hope that you will be able to solve the performance problem very soon. For one year, I have been producing perfectly clean STLs that have been accepted by Shapeways in minutes. The introduction of "Mesh Medic" feels like a step back to me, as it takes ages to evaluate my perfectly clean meshes, and now it starts rejecting them.

    Oskar
     
  5. arno
    arno New Member
    Hi Oskar,

    I think the models got queued, due to the server being busy. Eg, the upload date for model Sixth Sense v19 - size 64.stl is logged as 21 July 2010 18:36, but the checks only started at 21 July 2010 21:15 and your mail was send at 21 July 2010 21:16. Checks itself are not slow, but I need to find out why they started that late. Sorry.

    About the 'perfect' stl. I checked our backend logs and had the file you send by mail looked at. Both the log and Magics claim the model has inverted normals and other issues (probably caused by the normals not ok). So I am sorry to say, but it looks the model somehow was not perfect this time?

    Meshmedic tried to repair it, but in the process the model became non-manifold (it had too many problems). That is why you got the mail about not being manifold. CS will try to repair your model manually and will you inform about the results.

    I hope this is of help,

    kind regards, Arno

    PS: I have attached a screenshot of the Magics analysis.
     

    Attached Files:

  6. Oskar_van_Deventer
    Oskar_van_Deventer Well-Known Member
    Hi Arno,

    This helps a bit, but not a lot.

    First of all, could you next time try and make the IT system send me error messages what I am doing wrong, not what your system is doing wrong, please?

    I found and corrected the inverted normals. Still, my STLs are rejected. I'll send them to you by email again.

    Thank you for your help and patience.

    Oskar

    > CS will try to repair your model manually
    That is very kind, although I prefer to provide clean STLs myzelf.
     
    Last edited: Jul 22, 2010
  7. arno
    arno New Member
    Hi Oskar,

    Sorry for the confusion. Indeed you get only the latest error, not the error why meshmedic was started. We'll work on that.

    In the mean while, we'll check your models. And check our upload tool chain, coz now you might have surfaced an issue. Sorry for that.

    Thanks for your patience.

    Kind regards, Arno