Where's "Full Color Sandstone"

Discussion in 'General Discussion' started by focomoso, Oct 17, 2011.

  1. focomoso
    focomoso New Member
    Hi all,

    I'm a 3d designer / animator looking into using shapeways to print some of my characters for a presentation (and, if all goes well, for possible sale).

    I exported a test character in .dae format and zipped it up with the textures. The model came in fine, but the textures don't seem to have made it (or the system didn't recognize them) as the preview pic is all gray.

    Also, the "Full Color Sandstone" option seems to be missing from the materials list.

    Any thoughts on what I might be doing wrong?

    Thanks,

    James
     
  2. Magic
    Magic Well-Known Member
  3. stannum
    stannum Well-Known Member
    Wavefront's .obj supports colors too. But not tested with SW upload process yet.
     
  4. focomoso
    focomoso New Member
    Thanks Magic. That page helps (not sure why I couldn't find it before). It looks like I have some more work to do because I suspect vrml doesn't support multi-subobject materials either...
     
  5. Magic
    Magic Well-Known Member
    Yes, all must be in a single texture and I am currently struggling to be able to map subtextures to some parts of the model... :cry:
     
  6. stefan_z
    stefan_z New Member
    VRML + referenced JPG texture works for me.

    If you have to combine multiple textures, try the C4D / Bodypaint "Texture Bake" function...
     
  7. I've tested with multiple texture files and VRML in Rhino.
    You have to select VRML2 on the export to make it work.

    It took me a long time to figure out! But it's quite easy from Rhino. Not sure about other programs.

     
  8. stefan_z
    stefan_z New Member
    But does this work with shapeways?
    Their page says "one texture only" somewhere...
     
  9. focomoso
    focomoso New Member
    3ds max has render to texture, but the process is a not so straightforward because if you have multi-subobject textures on your model, you have to flatten the uv map... I'll post the workflow when I get it to work.

     
  10. stannum
    stannum Well-Known Member
    Yes, multiple image files work. The color zones here come from one image, the stripe zones are from a different file. It was uploaded as zipped .wrl plus two .png.
     
  11. Hey everyone, sounds like this process varies a lot depending on the software.

    If you'll post instructions, I can get the tutorial page updated to get the information to everyone.
    :)

    Is VRML2 a difficult format to export to?
    I would like .dae or .obj myself, but it would be good to get an idea of what file formats and instructions would be helpful for everyone.
     
  12. focomoso
    focomoso New Member
    If I can get this to work in max, my life will be much easier! What did you export from?
     
  13. stannum
    stannum Well-Known Member
    Blender.
     
  14. focomoso
    focomoso New Member
    So 3ds max export to vrml2 works with multiple textures flawlessly. You can see it in action here: color cube. Each color is actually a solid color map that uploaded with the .wrl with no problems.
     
  15. Magic
    Magic Well-Known Member
    There are a lot of way of applying different parts of the same texture on a model in 3DS Max: I guess there is one that works better than another...
    I still have to found out which one...
    :(
     
  16. Patron_Vectras
    Patron_Vectras New Member
    Howdy! Does Shapeways have plans to start using .KMZ files for color Sketchup uploads?
     
  17. akwhitacre
    akwhitacre New Member
    Is this something folks have successfully tried when exporting from Sketchup Pro 8? I'm looking to print an object with multiple textures and colors as full color sandstone, but sadly no matter what filetype I export to, the resulting object on Shapeways is gray.

    For anyone who's had success exporting from Sketchup to full color sandstone with multiple colors and textures, what settings or steps worked for you? Is there something I should be watching out for besides the 2mm minimum width requirement and being sure to use VMRL?

    (And do I understand it right that VRML includes WRL + images?)

    Any help is much appreciated since this is for my wife's birthday present. :p
     
  18. Sounds like Im the only one who uses .x3db :)

    In my experience, colour models for FCS are very finicky, ie getting the texture to upload with the model correctly to shapeways can be a battle.

    Theres various things that can go wrong, but I can suggest a few things - first make sure the texture is mapped to every face on the model, in the past even having one face which hasnt got the texture applied will cause shapeways to reject the texture or be unable to find it.

    Make sure your applying the exact same texture to the model which your also putting in the .zip and that the name is exactly the same.
    I use Blender and, for example, if you open a 2nd version of a image in the program it will be named texture.001.jpg, even though the source image is named texture.jpg, exporting that model with texture.001.jpg applied to it and putting it in a .zip with texture.jpg will result in a non-textured model on shapeways.


    As for the FCS material not appearing, try going into the edit page for the model on shapeways and re-enable the materia, FCS could just be disabled as a material option there, its happened to me before.

    I dont know how this would work in other programs, or with other model formats for that matter, but those are some of the issues I've encountered personally.


    *Edit* Whoops, didnt realise how old this thread was...
     
    Last edited: Mar 11, 2012