We're doing a release today! Here's what's in it.

Discussion in 'Official Announcements' started by ana_xyz, Mar 9, 2012.

Thread Status:
Not open for further replies.
  1. ana_xyz
    ana_xyz New Member
    Hey all,

    Today we're pushing a big release to Shapeways.com and I wanted to give you a run down on what's in it. The changes are broken down below into which area of the website we've worked on, and we get into further detail from there.

    Design Update
    * New look for products across the site!
    * New look for product detail page!
    * Faster page loads for most pages!


    Gallery
    Categories:
    * Popular Shops: The Shops page used to display the most recent shops, most of which hadn't been properly setup yet! Instead, we've got...
    * Per Page: We've changed the number of 'Rows' to be called 'Per Page' which controls the number of items displayed per page. It works more or less the same as before, just has a new name and different numbers.

    * Removed: Search Inside - Instead of searching inside the gallery, you can now use the new and improved search box in the top right to find what you're looking for.

    Search
    * Facets - You can now filter your search results by a few different
    criteria. We hope this will make it easier to find all the cool stuff
    on Shapeways!
    *** by Material
    *** by Price
    *** by Category
    *** by Customizable

    ** In Progress: Relevance
    ** Removed: Google Site Search
    ** Removed: Advanced Search


    Product Detail Page
    * Images: We've bumped up the image size to really make your products shine. The new image selector also loads faster and lets users easily click between your images, videos, and 3d renders.
    * More from this Designer: To increase sales of items in your shop, we've added a 'More from this Designer' area which features your popular items.
    * Pin It Button: With the rising popularity of Pinterest, we've added the ability for users to 'Pin' your designs and share them with the world.


    My Models
    * Add to Cart: You can now add models to your cart directly from your My Models page. Currently, the button will add one model in the default material to the cart.
    * Pending Results: Each time you update one of your models, you can now see how it will appear across the site! Because of this, we've introduced a small icon on the 'My Models' page along with a note to let you know when pending changes are being updated.


    Shop Page
    * Removed: Shop Categories
    Shop categories took you off of one shop and onto another. We want to encourage people to explore your shop more deeply, instead of to leave.


    Coming Soon
    * Better search relevance
    * Improvements to Model and Shop management


    In preparation for this release, we've exposed these changes to a handful of users, something we will be continuing, and expanding in the future. This has already helped us identify and fix key issues.


    Finally, I'm sure you'll still have additional thoughts, suggestions, and will notice things we've missed. To discuss those, please head on over to this thread. We will be considering fixes and further improvements after the release, based on that discussion.


    Thanks!
    Ana
     
    Last edited: Mar 9, 2012
  2. mctrivia
    mctrivia New Member
    Last edited: Mar 9, 2012
  3. abite
    abite New Member
    The new UI looks pretty better and much faster. Thanks as one of users.
    However, I have checked the [Select Country & Currency] option in the [My Models] since last night, but it does nothing. You cannot get $ values.
    It seems a just simple bug that can be fixed soon, so I wrote down here, not to the suggestion thread.

    PS. API doesn't work either... at this moment.
     
    Last edited: Mar 10, 2012
  4. robs_mw
    robs_mw Well-Known Member
    Hi,

    bugs?
    1)My public shop tells me I'm selling 9 products, but more are (correctly) shown...not sure how you are counting?
    (this miscounting also happens in the shop sections, mostly less, sometimes more are counted...)

    2)My shop page shows all my 17 products, but the 'per page' indicates only 12 are shown...?

    3) I sometimes see the text 'no local config file' next to the Facebook like symbol in the Shop Details box.

    question:
    1) how can I see in the 'My Models page which models I have released to my shop? As the shopping cart icon is shown with every product now...this is not so handy...

    2) in my models you have now 12 or 36 products per page. any possibility to set the default to 36? (seems to be 12 now).
    If there are more then 12 products, it might be an intelligent solution to set the amount to 36 right away?

    BTW, the shopping cart API seems to be working for me (not sure that's the API the last message was mentioning?)
    Also the Shop Sections seem to be working, as is the $ currency.

    BR,
    Robert
    http://www.shapeways.com/shops/rmw
     
  5. abite
    abite New Member
    Hi Rebert!
    Can you see price in dollar currency in your [My Models] page?
    The shopping cart page shows the dollar currency, but nothing happens when I choose $ in the [My Models] page.
    ...If you can, it seems that I'd better checked with other browers, not Explorer.
    Now, the submitModel function of API doesn't work for me. I cannot send a file using the function now, but it was ok before updated.
    Let me check any returned error message.
     
  6. stop4stuff
    stop4stuff Well-Known Member
    abite, how do you try to change currency in your [My Models] page? The option is there on individual model pages and works for me using ie8.

    Paul
     
  7. DarioScapittaDesign
    DarioScapittaDesign New Member
    I'm loggee using Explore and on the Home Page under the "MORE BLOG POST" and "LATEST FORUMPOST" there is a list of "UNDEFINED" and I can not see any forum last title. if I click on UNDEFINED I'm redirected to this page, check the picture:

    Untitled.jpg

    Someone of you can see the same?
    Cheers.
     
  8. stop4stuff
    stop4stuff Well-Known Member
    Yes, I get the same using IE8 WinXP whether logged in or out, but it is fine with Chrome - this was reported yesterday, but Shapeways Brad couldn't replicate the issue.
     
  9. abite
    abite New Member
    Hi Paul. Thanks for checking.
    I've also tried it using Crome, but it was same.

    What I tried is... go to [My Models] page, go into an individual model page, click on [Select Country & Currency] option, select $(dollar), and then [submit] button. Nothing happens. In that option, [Choose Country] option also doesn't work either.

    If I go into [Edit Product] from the same page, it shows the another select option for changing the currency. It looks same as the last UI design. It works fine only in the page itself, but if I change the [Edit Product] option to [OFF], the next following page shows still EURO with the country image error.

    I think some jQuery functions don't work properly at this moment.

    Dario Scapitta Design. Same issues to me.
     
    Last edited: Mar 10, 2012
  10. stop4stuff
    stop4stuff Well-Known Member
    I did have a similar issue yesterday for a little while, my browser is set to clear temporary internet files on exit, and the country/currency selector works fine now - perhaps clearing your temporary internet files might solve the issue?


     
  11. NovastarDesign
    NovastarDesign New Member
    did all the perma links also change ?? Now it shows a different one then before...
    if this is the case it would be quite bad, because i have many links in other websites, which now not seems to work

     
    Last edited: Mar 10, 2012
  12. abite
    abite New Member
    Paul. Thanks for checking again.
    I did clear temporary internet files. Thanks.
    Oh~ if I type some country names, the country selector works.
    However still cannot be submitted by [Submit] button.
    I have tried using Explorer 8, Crome and Safari, and got same problem till now.
    If you all do not have the same issue, it must be my com problem. :cry:

    Novastar Design~ Same here, so I really busy now to edit some codes in my website.
    However, pretty good to experience the NEW UI design.
     

    Attached Files:

    Last edited: Mar 10, 2012
  13. robs_mw
    robs_mw Well-Known Member
    Hi all,

    The issue regarding changing currency, seem to work for me, both in FF as in IE, both as being logged in as also when not logged in.

    I tested some permalinks, they all still work for me. But I have noticed earlier already, that -maybe when you upload a new version of a model-, you get a different permalink. But is all worked/works.

    Another bug I noticed however:
    only with IE 8 (not being logged in & I cleared cache already and restarted).

    When I change currency, in the material list, I get to see ALL materials, also the ones marked as 'not visible to public'. This is only the case with IE (FF no problem), and only after changing currency (before that it was fine in IE). Note I'm not logged in.
    (see attached screendump)

    Hello Shapeways:
    bad practice to do a new release on a Friday ! (unless your development/support team is working today/tomorrow, which I don't expect, but maybe you surprise us?).

    Cheers,
    Robert
     

    Attached Files:

  14. stop4stuff
    stop4stuff Well-Known Member
    Looks like the permalinks have changed, but the old one is still forwarded to the right model page (for me at least)
     
  15. NovastarDesign
    NovastarDesign New Member
    well the perma links not work for me anymore.....i get no traffic anymore to my shop...;-(
    Nice to make a new web design, but do it with proper testing before
     
  16. NovastarDesign
    NovastarDesign New Member
    also google analytics not seems to work anymore for me....
    do you guys experience the same ?
     
  17. robs_mw
    robs_mw Well-Known Member
    He again,

    Got to correct myself regarding the permalinks, as I found one that indeed doesn't work anymore!!...

    error returned:
    "Sorry, you don't have permission to perform this action"

    This was using quite an old permalink, and it goes to a 'gid-ug' format as described below; this one indeed goes to a model id that I don't recognise/is not mine...so something screwed up

    I also noticed the some permalinks revert to this format:
    http://www.shapeways.com/model/286023/
    while others (older) revert to this format:
    http://www.shapeways.com/model/286023/fire_extinguisher_cont ainer__ho_1_87__set.html?gid=ug

    In this case both work (I collected 2 different permalinks over time for this model).

    BR,
    Robert
    unofficial beta-tester
     
  18. macouno
    macouno New Member
    Hmm... I was deleting some of my 2000+ models and can now no longer access the my models page. Something to do with the update?

    Nice stuff btw
     
  19. stop4stuff
    stop4stuff Well-Known Member
    Google Analytics seems to be working ok for me, remember though that the analytics data on google is updated once in a 24 hour period, which currently starts at 08:00 GMT.

     
  20. abite
    abite New Member
    Some pages of My website are connected to Shapeways, but most of all don't work now. As Robert mentioned, I have same problems in the permalinks.
    Several hous ago, I noticed the UI design was changed suddenly. Since that, I have been struggling for several hours... :cry:
    I am trying to check the soap API function to be able to submit files from my website.
     
Thread Status:
Not open for further replies.