UV Mapping to Sphere (washed out image)

Discussion in 'Software and Applications' started by 3DLudi, Mar 3, 2014.

  1. 3DLudi
    3DLudi New Member
    Note: I learned Blender in two weeks watching Youtube videos so be nice (lol).

    I have been playing around with UV Mapping and ran across something odd which I cannot seem to figure out. Was hoping a more experienced hand could point me in the right direction. Mapping to a flat surface seems to be OK but when I map something very bright to a sphere (think sun with glare) the UV mapping turns out dull and I cannot figure out why. I thought this would be easy. I simply want the image, exactly as it is, applied to the mesh.

    See Image01 for an example which I just did for testing.

    Normally I do not think this would cause any problems, but Shapeways uses the Dull mapping and not the bright image I provide.

    Now I found a setting under Material >> Shading : Shadeless (circled in green in Image01 -- lower right) which does seem to fix the problem in Blender. See Image02 for the visible change Now everything looks correct and is nice and bright. Just like the original image. But if I import this new model to Shapeways the widget they use for rendering does not look correct. It looks completely washed out. See Image03.

    My thoughts on possibilities.
    1> I have a setting amiss in Blender which is causing issues.
    2> Blender model is OK but display widget Shapeways uses on website cannot properly render. (but model would be OK when printed).
    3> Blender model is OK but Shapeways will print exactly like it looks in the Widget.
     

    Attached Files:

  2. mkroeker
    mkroeker Well-Known Member
    Make sure that you chose a file format that can actually convey the colormap information - WRL and DAE do, STL or OBJ do not. Also check if there is a
    setting in Blender that might export your object with some whitish base color in addition to your UV map.
     
  3. 3DLudi
    3DLudi New Member
    Thanks for the quick reply! I was out of pocket for a while so I was unable to reply.
    I am, currently, using the x3d format. For no other reason that it was the first one I tried to use for full color and it worked.
    It is worth noting that the setting Material >> Shading : Shadeless in Blender is the only changes I made to the model.
    If I do not use it the renderer in Shapeways looks fine (though it is dull unlike the original PNG).
    If I do use it the renderer in Shapeways looks almost completely white though the preview in Blender looks great.

    >> Also check if there is a setting in Blender that might export your object with some whitish base color in addition to your UV map.
    I had not considered this. I will Google around and see if there are any further settings I can mess with.

    Thanks so much though for the feedback thus far...
     
  4. Keymaker
    Keymaker Well-Known Member
    That dull look you get is from generated "shadows" in viewport. These shadows provide information about form of your mesh so it is easier for you to see how it could look real life. I believe that similar shadows are rendered in SW viewer...

    When you check shadeless option it will remove any shadowing in viewport and it will give you straight color. When you export model with shadeless material, than this information is probably written in that material and shapeways viewer is trying to also create that shadeless view but obviously it did not work.

    In your case you can ignore that "dull" look, because printer will always look for color stored in texture or in vertex color => without additional shadows.


    And before you place your order you should look at other models printed in FCS so you can see that not all colors will be printed as you can see in blender, but they can be less saturated and blurred... But that is problem of printing process, not in exporting your model.
     
  5. 3DLudi
    3DLudi New Member
    Mah-hah!
    So the online viewer is a little picky about the shadeless setting. Not really surprised considering the wealth of settings Blender has.

    >> In your case you can ignore that "dull" look, because printer will always look for color stored in texture or in vertex color => without additional shadows.
    Perfect. Just what I needed to know. I can ignore the dull look I have been getting...
    Thanks so much!
     
  6. mkroeker
    mkroeker Well-Known Member
    You might also want to try previewing your x3d files locally with a vrml/x3d viewer such as view3dscene to see what actually ends up in the exported files (as opposed to what you see in blender with all its additional effects).