Uploaded models not showing up in 3D view

Discussion in 'Design and Modeling' started by AotrsCommander, Mar 24, 2010.

  1. AotrsCommander
    AotrsCommander Well-Known Member
    I updated a few (well, most, actually) of my models yesterday (having got my first order through and making adjustments to what will be my next set of prototypes.) However, despite not intentionally doing anything different with the uploads, some of the models are not displaying in the 3D viewer on the webpage. It says it's loading, and then brings up the windom, but it's empty.

    It struck me as a bit strange, as until yesterday I'd not knowingly had a problem.

    I left it overnight and tried again, in case there was some load/bandwidth etc problems, but it's still doing it.

    Being a sort of paranoid soul, I did keep the (unmodified) older versions of the files (which did work in the 3D viewer)
    and have been experimenting to see if they work and they sometimes do and sometimes don't.

    In addition, one of two of the updated models are displaying slightly differently in the renderer: thus




    All I did to the second one was increase the size of the top front wedge and the lower front wedge (as you can probably see); I didn't touch the surface with the spherical depression at all. I wasn't overly concerned, as I assumed it was just part of the render, but it struck me as a bit odd. The first image was captured from the unmodified file today, as I was checking on a temporary upload to see if it was some glitch in the uploading sequence (IE and/or Virgin Media have been extremely uncooperative the last few days with a bout a 30% fail rate in loading webpages.)

    I've attached one of the new files that's causing the problem (a torpedo destroyer which is displaying in the render right, but not in the 3D).

    If anyone could shed some light on this, I'd be grateful.

    Attached Files:

  2. arno
    arno New Member
    I agree it looks like an artifact in the thumbnail renderer.

    I have created an internal ticket to have it investigated and find the cause. This may take several days (our thumbnail expert has some holiday ;) )

    Kind regards, Arno
  3. AotrsCommander
    AotrsCommander Well-Known Member
    I think I tracked the issue. One of my modifications had been to fiddle with the normals on the models that were supposed to be hollow (as I discovered the known issue of the volume calculator not recognising them and was thus supposed to be altering them so it did.)

    I selected the relevant internal verticies in Blender and told it to recalculate normals inside, and this appears to be where the problem arose. Your error software did not seem to recognise this as a problem. However, I found a very useful script on the forums which calculates the volume and cost for a Shapways model. I discovered that several of the problem models were registering as negative volumes!

    So that it clearly where the problem is. I've gone back and re-imported all the models into Blender. Then I selected everything and started with a commanded recalculation of normals outside; something I don't think I did when the problem started.

    Before, when the models had worked, I had done a normal recalc outside (as your error software told my I had inverted normals). But when I *manually* ordered an recalc inside, on the relevant verticies (without doing that) Blender and your software seemed to accept it, but your image and 3D renders clearly didn't.

    So What I did this time - and it appears to have worked, as all the models are now displayed in both 3D and image correctly - was import the model into Blender, do a recalc outside of all normals, then select the inside verticies and do a *flip* normals (rather than recalc inside).

    Being a Blender newb, this never would have occured to me before. But it clearly the difference between normals being flipped and recalculated inside is similar but subtly different.

    Anyway, I thought I should leave you the feedback so if the issue arises again, ou might have some idea what might be causing it!
  4. bartv
    bartv New Member
    Hi Aorts Commander,

    the file 'StoneportalTorpedoDestroyer1solida.stl' is not the model that you show in your screenshots. Could you mail both STLs of this model (the one that renders fine and the one with the artifacts) to bart@shapeways.com?