Update 3D model reports an error but same file works if new

Discussion in 'Bug Reporting' started by decapod, Jun 26, 2012.

  1. decapod
    decapod New Member
    Updating a model from the Edit model screen (selecting mm as the scale) sends the "There's a problem" e-mail

    "Based upon the size, volume and wallthickness of your product there
    is no printer available which is able to print your product.
    Please adjust the volume and/or size of your product."

    and yet if I upload the model as a new model (selecting mm as the scale) it works correctly.
    Tried several times.

    New model:
    Old, trying to update:

  2. stonysmith
    stonysmith Well-Known Member Moderator
    I've seen this happen when the (new) model didn't fit the design rules such as minimum wall thickness, etc.

    On the new model, all materials are available by default. On your old model, you've got several materials turned off. Whichever material it is that IS working... if you enable it on the old model, then the upload will work.

  3. decapod
    decapod New Member
    Brilliant - that worked, Thanks.

    It's really odd, the old model was only allowed FUD which has the finest tolerances.
    The model is well within the material tolerances.

    Looks like a bug somewhere, at least I have a workaround now.
  4. stonysmith
    stonysmith Well-Known Member Moderator
    Check my two postings here..
    http://www.shapeways.com/forum/index.php?t=msg&&th=7 825&goto=41969#msg_41969

    If your model contains many shells.. it is possible that Netfabb is having trouble measuring one of them properly.

    There is also the chance that you have one or more "degenerate shells".. where the volume of the shell is zero. That drives the automated checker to reporting an error when it might actually be okay.

    This is partly why the automated checker is (has been) difficult to implement. There's still a bit of human judgement required.