Trouble with Normals in Blender

Discussion in 'Design and Modeling' started by averymonsen, Jan 18, 2010.

  1. averymonsen
    averymonsen New Member
    Hey there.

    So I've recalculated the normals, and Blender says they're all facing out, but Shapeways disagrees and won't let me upload it. I'm new to all this, so it's totally possible I'm just missing something simple.

    I'm attaching the .blend and .stl files for you to look at, if you're interested.

    Any help would be much appreciated, y'all. Thanks!

    -Avery
     

    Attached Files:

  2. Mainstream256
    Mainstream256 New Member
    Hi there,

    you have inverted Normals on the legs off your figure. Simply go to edit mode and hit A (select all) and CTRL+N(recalculate Normals).

    This should fix it ...
     
    Last edited: Jan 18, 2010
  3. EricFinley
    EricFinley New Member
    Also, sometimes with some very weird nonmanifold meshes you can get a situation where Blender cannot figure out which way to point the normals so that they are simultaneously "outward" and "coherent." My recommendation is always to make sure you're fully manifold before laying a finger on normals issues.
     
  4. GHP
    GHP New Member
    My experience is that Blender sometimes gets the normals wrong even when the mesh is manifold - and I don't think Shapeways tells you about problems with the normals until the mesh has passed the manifold test.
     
  5. GHP
    GHP New Member
    Hi, I opened the STL file in MeshLab (where you can see easily the faces with inverted normals on the back legs), and used the "Re-orient all faces coherently" option on the "Normals..." submenu of the "Filters" menu, and this seems to have fixed the problem. This solution isn't guaranteed either, but it often succeeds where Blender has failed.
     

    Attached Files:

    Last edited: Jan 19, 2010
  6. averymonsen
    averymonsen New Member
    Awesome. Thanks, everybody.