To all 3ds max users: Turbo-/Meshsmooth causes non-manifolds???

Discussion in 'Software and Applications' started by Laserschwert, Mar 2, 2010.

  1. Laserschwert
    Laserschwert New Member
    Has anybody else noticed this? I simply don't understand it... I have a perfectly fine character model, which is quite lowres. I can upload it, and it gets no errors. As soon as I add a Smoothing modifier (no matter if it's Meshsmooth or Turbosmooth) the object gets a "non-manifold"-error when uploaded.

    The model consists mostly of quads (but even if it didn't, it shouldn't get non manifold, right?)
     
  2. Eeppium
    Eeppium New Member
    I had similar problem with blender´s subsurface modifier.
    the ss. stretched the verts radically and showed up as non manifold. blender and meshlab didn´t see any problems with the mesh, but when i send the file to shapeways, they returned with a pic showing the errors.
    they apparently used Netfabb for finding the errors.

    i got rid of the problem by adding vert loops near the twisted areas.

    the area looked bit like this:
    verts.jpg
     
  3. virtox
    virtox Active Member Moderator
    I use it all the time without problems.

    The only problems I had were with relatively low-vertex corners (compared to the rest of the model) and hard creases/folds.
    Both have as effect that the mesh will start overlapping inside/outside or loop in on itself.

    If you want, PM me the low-res max-file, and I'll see if I can try to find a cause for your problems

    Stijn
     
  4. Laserschwert
    Laserschwert New Member
    I have made some progress:

    I think the error lies in max's Collada-exporter. When Turbosmoothing the model and exporting it as Collada, the upload at Shapeways give's me errors. But: The error(s) can't be seen in Shapeways' "error-viewer" (i.e. nothing is red).

    Importing the Collada model in Meshlab doesn't show any non-manifold faces or edges, but non-manifold vertices... lots of them, all over the model. They can easily be fixed in there, but that's not even necessary, because I've found out another thing:

    Exporting from 3dsmax as Wavefront OBJ results in a clean mesh... Meshlab doesn't find any errors. And when exporting that mesh from Meshlab as STL, I can upload it to Shapeways without problems.

    That's a huge step forward, but I still have a problem: I want to do a full-color print and my model uses three different texture-maps. Unfortunately Meshlab only supports one texture per model (and I'm not even getting a hang of how to work with textures in Meshlab at all). I guess I have to get some other tool to export my textured model to VRML or X3D...
     
    Last edited: Mar 3, 2010
  5. virtox
    virtox Active Member Moderator
    ? 3D Max exports STL and VRML just fine ?
    No need for meshlab there ?

     
  6. pior
    pior New Member
    To avoid such thin areas, make sure that your model is mostly made of quads, and that the edge flow makes sense (mostly grid-like).

    As for export, yup VRML is all you need. Just dont look for it in "export selection", its not there. It's in "export" (I guess because VRML is a scene format?) There is an option to export only the selected object from the exporter window itself IIRC.

    Dont forget to put the precisison to the max in the VRML settings ; if not, your model will have small bumps once exported.
     
    Last edited: May 22, 2010
  7. WelshDesigns
    WelshDesigns New Member
    I see meshsmooth creating problems all the time, when something has a shape prone to curves crossing each other. the straight lines of a poly model might be fine, but when you do meshsmooth curves come into play to "smooth" the object. Play around with Nurbs, Quad and classic as they are all different. BTW, make sure to watch the textures, they WILL move around, so depending on the maping, texture joints, or edges may provide undesirable results. And export a VRML, it works fine with multiple textures, just be aware it's probalby going to export in meters no matter what you tell it to do. :) so you may have to scale your model right before export to meters size, then export.