The Shapeways Creator

Discussion in 'Design and Modeling' started by joris, Aug 12, 2008.

  1. joris
    joris New Member
    So what do you guys think about our creator?
     
  2. Launch is ok.
    Then I guess I clicked too fast the 3) and 4) buttons, as i could not go back to either 1) or 2) : the buttons flashed but did not want to unfold. And no way to restart from scratch without closing and relauching the app : step 4 should have a "cancel/restart" button.

    A second try was ok. Great to highlight the problematic parts within the text, very nice. Too bad there can be no lower case, no accents, not even any punctuation :(
    I understand it can be hard to attach a dot or a comma, but it would be an interesting addition.

    Another idea : if it is possible, add a visual indication in the textbox were the message has to be written, so that it is possible to see were is each "newline" on the lamp.

    Another one : a night mode for the 3D GL lighting, as if a light was inside, and the ouside stays darker. No need to be photorealistic, but it can help to have a idea of how it will look when lighted. If the user can switch easily from "default lighting" to "night mode" it would be great !
     
  3. madebydan
    madebydan New Member
    Seems like a fantastic idea but I tried to use it and it generated an error and wouldn't open.

    Any idea why that could be happening?

    cheers
     
  4. WetMorgoth
    WetMorgoth New Member
    Andre:

    The ability to start/restart the editor is something that should be coming shortly. We had a couple of bugs with it, so disabled it before the launch. Probably within a couple of weeks we'll have that available (we're all a Siggraph right now)

    As for the internal/night light, that functionality is already in the code. It was disabled based on some internal design decisions from our UI design people. The initial design guidelines were to make it like a wizard with a series of steps where one fed in to the other. There's actually quite a few of these UI design decisions that need to be looked at based on some initial feedback from like you guys are the codegeeks that we are :)

    As for lower case support. We do have that built in. However, as we were doing testing we were finding that more than 90% of the models had structural problems because characters were not linked together either to the row above or below. Characters like i and j were even more difficult to deal with. It wasn't that we could not lay them out, it was that it was almost impossible to build a poem that was not structurally sound. Non-english characters were even more problematic, so we limited the fonts and character sets that were available for now.

    madebydan, if you can send us the actual error message that would help. There was some little bits of server instability yesterday with the launch that caused a few problems. It may be related to that.
     
  5. madebydan
    madebydan New Member
    It first pops up an error saying 'cannot launch the application'
    Then I click details and get this.

    <?xml version="1.0" encoding="utf-8"?>
    <!-- JNLP File for the Shapeways Application -->

    <jnlp spec="1.5+" codebase="http://www.shapeways.com/modules/udesign/ext/client/" href=" http://www.shapeways.com/modules/udesign/utils/openclient.ph p?model=2748&editor=1">
    <information>
    <title>Shapeways Editor</title>
    <vendor>Yumetech, Inc.</vendor>
    <homepage href="http://www.shapeways.com"/>
    <description>Shapeways Application</description>
    <shortcut online="false">
    <menu submenu="Yumetech Applications"/>
    </shortcut>
    </information>
    <security>
    <all-permissions/>
    </security>
    <resources>
    <j2se version="1.5+" java-vm-args="-Xmx512M -XX:MaxDirectMemorySize=256M -Dsun.java2d.noddraw=true" href="http://java.sun.com/products/autodl/j2se" />
    <jar href="lib/udesign_1.2.2.jar" />
    <jar href="lib/aviatrix3d-all_2.0.0.jar" />
    <jar href="lib/chefx3d_core_2.0.0.jar" />
    <jar href="lib/j3d-org-all_0.9.0.jar" />
    <jar href="lib/vecmath.jar" />
    <jar href="lib/fastinfoset_1.2.2.jar" />
    <jar href="lib/xj3d-norender_2.0.0.jar" />
    <jar href="lib/xj3d-interchange-loader-av3d_2.0.0.jar" />
    <jar href="lib/uri.jar" />
    <jar href="lib/vlc_uri.jar" />
    </resources>
    <resources>
    <extension name="jogl" href=" http://download.java.net/media/jogl/builds/archive/jsr-231-w ebstart-current/jogl.jnlp" />
    </resources>
    <application-desc main-class="udesign.UDesignViewer">
    <argument>modelID=-3</argument>
    <argument>sessionID=tmcg4osj3ber1k4sidgm1ml3p3</argument>
    <argument>soapServer=http://www.shapeways.com</argument>
    <param name="backgroundColor" value="0.8 0.8 0.8 0.57 0.78 0.93"/>
    </application-desc>
    </jnlp>

    Does that help?
     
  6. robert
    robert New Member
    Do you have Java installed on your computer?

    Best regards, Robert
     
  7. jochem
    jochem New Member
    Last edited: Aug 21, 2008
  8. WetMorgoth
    WetMorgoth New Member
    Jochem,

    On the drivers page, you should note that laptops will generally require you to get the drivers from the laptop vendor, not that of the chipset. For example, the Dell latitude laptops will not install the drivers directly downloaded from Intel, you must use the ones directly from Dell.
     
  9. bhearn
    bhearn New Member
    I'm unable to get it to launch on OSX 10.6.1.

    I get "Error: sealing violation: package javax.vecmath"

    :(

    10.6 comes with Java SE 6 (32-bit and 64-bit); I manually installed J2SE 5.0 (32-bit and 64-bit) as well to see if that helped. No dice.
     
  10. Avi
    Avi New Member
    Hi There,


    I'm lost. Where do I get Creator?
    I have poked arund and foud all sorts of cool stuff but not Creator.

    Can you point me in the right direction please.

    Thanks
     
  11. ArnoudV
    ArnoudV New Member
    Hi Avi,

    In the header of our website you see two pink buttons. The first for uploading en the second for the creators.

    grtz
     
  12. cpw11
    cpw11 New Member
    I need help:
    1) Does the Photoshaper look good in colors besides the default White? If, what is recommended (and do you have any examples)?
    2) I added a message, but it appears on the back...isn't that going to look weird when the light shines through?
    3) In Step 3 of the creator, it has a checkbox, "For use with light"...what does that mean?

    Thanks for your help!
     
  13. robert
    robert New Member
    Hi cpw11,

    Thanks for trying out our Photoshaper! To answer your questions:

    1) The Photoshaper is only available in mono-color (either White, Limestone, Terracotta or Jeans Blue). We think it looks great! But then again maybe someone from the community can answer this? :)

    2) Yes, the message for on the back. It does look weird when you make it a LightSculpture. (see also next answer) This option is only applicable when creating a regular Photoshaper.

    3) The option "Use with light" changes the way the image is processed. The photoshaper will then become a LightSculpture which shows the picture in black & white when you hold it into the light.

    I hope this answers your questions!

    Robert
     
  14. cpw11
    cpw11 New Member
    Thank you! I plan on using this with a light behind it...so I should select the "Use with light"?

    It would be great if someone from the community can comment on the other color options...how they look with and without light behind it..
     
  15. robert
    robert New Member
    Yes, click on the "Use with Light" option!

    Cheers!

    Robert
     
  16. dr2chase
    dr2chase New Member
    Me too, same problem, everything is pretty much latest version, on a Mac.

    Apparently there is some sort of a classpath screwup, but it's a bit of a mystery, seeing as how I am using Java all the time in my daily work.

    Nope, I'm stuck, would nice to get some help here.
     
  17. dr2chase
    dr2chase New Member
    I thought I had posted a second message with some further information, but now I am not sure, but the behavior has changed as if my second message had been read.

    When I moved vecmath.jar out of the extensions directory, I started getting a new error complaining about the jnlp file lacking a jnlp element.

    But when I went back today, every time I tried to re-download/run Creator (because the older downloaded ones kept getting me the login message) every time I go to the page to download the Creator, it logs me out. I log in, it takes me to a different page, I try to go back, it logs me out.

    This stuff is interesting, but trying to get to the first step is a little tiresome.
     
  18. dr2chase
    dr2chase New Member
    To recap -- the sealing error occurs because there are two copies of vecmath.jar on the Java classpath, one in my /System/Library/Java/Extensions directory, the other in the Shapeways Creator JNLP. I am not sure which is "wrongly there", but one way to fix it, is to remove the one in the Extensions directory.

    Second, it seems to work better when started from Firefox, not Safari, there's some sort of an issue with being logged in to run the Creator.

    THIRD, the video/instructions on how to make a stamp pad are NOT confidence-inspiring. The words say "flip left-for-right", presumably because of the mirror image thing, BUT THAT DOES NOT HAPPEN IN THE VIDEO.

    And there is a button that I am not supposed to press -- is that "Flip high to low". Or, if I want the dark in my photo to be inked, am I supposed to press it after all? I think you need to coordinate your documentation with your tool.

    One thing that would help, if we are supposed to flip text so it will come out right, is to flip the text in the example ("stamp") inside the heart so that what you show us, is what we do.
     
  19. dr2chase
    dr2chase New Member
    Sigh, tried again, and this time the creator seemed weirdly disconnected from the UI. Changing from portrait to landscape did not change the display; uploading a file did not change the display.

    Is there any way we can get notified if/when this works reliably?
     
  20. arno
    arno New Member