The Return of Non-Manifold Model Issues

Discussion in 'Design and Modeling' started by OracleofWuffing, Apr 28, 2009.

  1. OracleofWuffing
    OracleofWuffing New Member
    It appears that we've got quite the running theme going on in this forum... :p

    I, uh, don't really know what to say, as I've been here before. I mean, I'm Importing it into Blender, and I'm able to do the non-manifold check from there, but after I've got that selected, whether I try to fill or delete things from there, it just seems like I'm doing things wrong. I'm certain the scale isn't how I want it, but that's because that's the last thing I adjust, after everything's manifold and ready for uploading.

    I have a number of older models that I'd like to try uploading, but they essentially get the same issue, so if you'd like to talk about the process, I'd really appreciate it so I wouldn't have to ask for help every time I have something new.

    Thanks in advance.
     

    Attached Files:

  2. jdavidbush
    jdavidbush New Member
    Hi Oracle,

    Cute model!

    Are you having trouble identifying the non-manifold edges/faces of your model or just having trouble correcting them in Blender?

    I don't have much experience with Blender, so I can't help you there.

    However, if you're just troubleshooting the problems, you might have some success using MeshLab.

    The first thing I noticed after loading the file was dark faces caused by a "dent" on the inside of the vase. That indicates that the "inner" surface is pushed out past the "outer" surface and will probably result in a reversed normals error later on.

    The second thing I noticed, after running "Colorize->Color non Manifold Faces", is that there are some non-manifold errors occurring in the flowers.

    Hope that helps,
    ~David
     
  3. RalphVdB
    RalphVdB Well-Known Member
    HI Oracle of Wuffing :cool:

    I took a look at your model...It had a lot of inverted normals, bad edges, noise shells etc in it...So i fixed it for you :nod:

    I uploaded and testet it for you. And now it works fine :D

    Have fun with it!

    Cheers,

    Ralph
     

    Attached Files:

  4. OracleofWuffing
    OracleofWuffing New Member
    Thanks for the advice and help, jdavidbush and Ralph... The school year's just rounding off, so I'm sorry I'm a bit late in saying so. I'll be resizing and uploading it shortly. :)

    In the meantime, I'll be looking at Meshlab and then working on this model, it was pretty much the "capstone" for my classwork, so it would be kinda neat if I could get this printed out, but I'm pretty much certain it has the same issues as the flower model. Everything else will be a whole lot simpler.
     

    Attached Files:

  5. RalphVdB
    RalphVdB Well-Known Member
    Hi Oracle of Wuffing

    would you please be so kind to upload it in a stl format :blush: then i will take a look at it for you

    Thanks a lot

    Cheers,

    Ralph
     
  6. OracleofWuffing
    OracleofWuffing New Member
    Here you go. I appreciate the help. I had it in an stl format because I was giving Materialize's Autofix process a try, but they said it couldn't be fixed automatically, so it looks like it needs some hands-on love.
     

    Attached Files:

  7. RalphVdB
    RalphVdB Well-Known Member
    Hi Oracle of Wuffing,

    i didn't forget you ;)
    I am getting my new licence for Magics this week, so i am a bit stuck fixing models ;)

    As soon as i am " fully functional" again, i will help you out!

    Cheers,

    Ralph
     
  8. OracleofWuffing
    OracleofWuffing New Member
    No worries, Ralph. I've been caught up in getting things moved home for Summer Break, so I've been less than "fully functional" as well.