Texture Will Not Show Up When Zip Is Uploaded

Discussion in 'Software and Applications' started by brando9g, Mar 27, 2018.

  1. brando9g
    brando9g Member
    I have tried multiple things and looked through forums all day without a resolution. I have tried zipped files of a DAE or a WRL file with a PNG which have uploaded but both ways without the texture. I did make the initial mistake of zipping a folder, but I am now just zipping the files. I lowered the resolution of my texture to 1024px. My model is from Maya and I have made sure that all history is deleted along with running cleanup. I exported DAE directly from Maya while I exported WRL through Meshmixer but with the same results. When uploaded to shapeways, the texture is recognized and checked green, but isn't visible on the model.

    I can only assume it has something to do with the association between the model and the texture, but I'm unsure what I'm missing.
     

    Attached Files:

  2. stonysmith
    stonysmith Well-Known Member Moderator
    Your WRL does not reference the PNG in any way. You need to work on re-applying the texture.
     
  3. brando9g
    brando9g Member
    Maya and Meshmixer keep losing it whenever I export/convert it to either DAE or WRL. Is there a program on the pc that is available that doesn't do that, am I missing something from Maya or Meshmixer (I'm using Maya 2016), or is there a way for me to alter the text doc to reference it? I cannot export to WRL through Maya.

    Thanks for the reply!
     
  4. mkroeker
    mkroeker Well-Known Member
    You can throw away the entire Color{} block under the "Shape" node, set its ColorPerVertex FALSE and add these lines
    before the "geometry IndexedFaceSet {" line:
    (note that while it works here, it may not always be that simple (when you have multiple textures, or a non-default mapping of the texture that requires a separate block of texCoord entries).
     

    Attached Files:

  5. brando9g
    brando9g Member
    Thank you for the help, though I still can't manage to get this to work
     
  6. brando9g
    brando9g Member
    I got it to work. I exported the model as an obj which automatically recognizes the textures, then opened it in MeshLab and it exported without issue. Meshmixer just doesn't want to export a functional WRL with a texture even though it can import with a texture. Thanks for the very quick response to help!