Struggling to get model ready for printing

Discussion in 'My Work In Progress' started by Evostance, Nov 8, 2012.

  1. Evostance
    Evostance New Member
    I've created a model of the iMac RAM Cover in Sketchup and uploaded it to Shapeways. Its a fairly simple model so i'm not really sure what the issue is.

    [​IMG]

    You can see by the images its a pretty close comparison, but I cant get it working.
    Any suggestions? The height of the model is 2mm with there being a ledge at 1mm heigh which is 1mm deep.. Not sure if this is too detailed for printing though?

    I can upload the skp if it helps?
    I've ever new to modelling and modelling for printing so bear with me :)
    Any help appreciated


     

    Attached Files:

    Last edited: Nov 8, 2012
  2. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Your picture isn't working, and what problem are you having with printing it?
     
  3. Evostance
    Evostance New Member
    OK, not sure why that is happening. No issues here.

    I followed the steps here, everything is fine and watertight:
    http://www.shapeways.com/tutorials/sketchup_3d_printing_expo rt_to_stl_tutorial

    I had an email which stated:

    Uh oh! Seems like your model needs a bit more love before our robots can work their magic.
    The 3D model 27" iMac RAM Cover you recently uploaded didn't pass all our automated checks, so it's not yet ready for 3D printing.


    The render via Shapeways is:
    [​IMG]

    I've uploaded the STL file for reference
     

    Attached Files:

  4. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I'm a little confused, it uploaded but says that your item needs more love? Did the dimensions come out as intended?
     
  5. Evostance
    Evostance New Member
    Yes. Its in my models but I got an email saying the above.

    The dimensions listed are:
    17.0 w x 0.2 d x 2.1 h

    And the size of the model was 170mm wide, 2mm high and 21mm wide, so they came out fine. Looks like Shapeways got the rotation wrong but that doesn't matter

    I guess by your comment, it shouldn't actually show in my models if it wasn't ready for printing?
     
  6. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Exactly, if it fails the tests, it shouldn't be available. What material are you aiming for?

    If you could, email service about it. They should be able to figure out exactly what's going on.
     
    Last edited: Nov 8, 2012
  7. Evostance
    Evostance New Member
    I've just gone with the white,strong, flexible one for now to see if it aligns correctly.

    Sent them an email too
     
  8. Fredd
    Fredd New Member
    That was a pretty nice model using Sketchup.:)
    I opened the stl, everything looked good. I am like you though the mm lip might be a problem. You know to select inches on the upload? Just making sure, heh. As for the odd renders lately, it seems that SW's up is Z, while forward is -Y in you model program, well least for blender
    Keith

    Ok, SU's blue axis is up on SW's render, while - Green is forward.
     
    Last edited: Nov 8, 2012
  9. Evostance
    Evostance New Member
    Thanks. Sketchup is quite powerful if you get some decent plugins etc. Not as good as 3DS Max or Blender, but they're much more complicated, and I don't plan on doing anything intricate anytime soon anyway.

    I dont think I selected anything on the upload. If im honest, I cant recall there being an option. Either way, its come out right. Model says:
    In: 6.7 w x 0.1 d x 0.8 h
    Cm: 17.0 w x 0.2 d x 2.1 h


    which is 170mm x 2mm x 21mm so its all good.
     
    Last edited: Nov 8, 2012
  10. JACANT
    JACANT Well-Known Member
    There are a lot of extra faces to your model. In Sketchup you need to delete all of the extra lines you do not need. If you don't faces will be created where you don't want them. Get your self a copy of http://www.netfabb.com/basic.php
    Open your STl file. The first thing you need to do is scale your model by 25.4 to make it the correct size. Go to Part - Scale. If you zoom in you will see many annomolies. Faces covering the edges of holes. Click on the 'Red Cross'. You have 77 shells and 388 holes. I have tried the automatic repair but it did not work. You need to go back to your original file in Sketchup and delete all of the extra lines. Then open it in Netfabb again to check it.
     
  11. Evostance
    Evostance New Member
    How do I go about doing that as they don't actually show up on Sketchup.

    Perhaps a limitation of sketchup?
     
  12. JACANT
    JACANT Well-Known Member
    Send me your original SKP file and I will have a look. By Pm or my email address
     
  13. Evostance
    Evostance New Member
    Thanks a lot :)

    I've just emailed it to you.
     
  14. Fredd
    Fredd New Member
    Evo, I uploaded it to SW from your original file Was perfect.I made sure to select inches while uploading it. No nasty messages.
    You said you never selected units, so I guess that when it was uploaded, SW decided it was too small(Default mm). SW will either bump the dimensions either up or down, if the size is either too small or large. I have seen that uploading x3D files, being too large.
    Well here is a good stl where it faces correct orientation.
    Thanks to Jacants advice above I recalculated the normals, which solved potential problems. The models normals were preventing volume calculations. I was reminded that if a model uploaded to SW in edit mode does not show volume, you have problems.
     

    Attached Files:

    Last edited: Nov 9, 2012
  15. JACANT
    JACANT Well-Known Member
    This file is a lot better than the one I downloaded.
    In Sketchup go to View - Hidden Geometry. As you can see, when the face is selected it is also selecting some of the holes where the hidden lines are. When you select the same face with the Hidden lines shown, the face alone is selected not the holes. If you look closely the lines on the side of a few holes are not touching. I think this is where the problem is. If you delete the hidden lines you will have to join the gaps between the lines around the holes.
    Hidden geometry.png
     
  16. Fredd
    Fredd New Member
    Ty Jacant, this is one of the reasons I uploaded Sketchup. To see problems other programs can cause. That is a great example
     
  17. JACANT
    JACANT Well-Known Member
    There still seems to be anomolies in the model. I created a new test file in another program similar to the one by Evostance. I opened them in Netfabb. Went to repair and deleted the top face to see inside. As the image shows the top model I created has no anomolies when the mesh is created. The yellow lines indicate holes. I don't know the answer to this. It is just the way different software export to STL I suppose. Unless there are more hidden geometry or guide lines.

    anomolies.png
     
  18. JACANT
    JACANT Well-Known Member
    I opened the file in Meshlab. Ran a few of the filters. The 'Remove Zero Area Faces' seems to work . Exported as STL. Open in Netfabb. Click repair, there are now holes in the surface where the anomolies where. Do an Automatic repair. Apply repair. Export as STL. Upload to Shapeways. Sorted.
    I will email you the fixed file.
    Meshlab.png
     
    Last edited: Nov 10, 2012
  19. Evostance
    Evostance New Member
    Thanks :)

    Good for future reference, however Im on OSX so can't use Netfabb

    Are there any other alternatives you know of?

    The only issue I have now is the scale of it is much much bigger than it originally was. I thought there might have been some import settings in Sketchup but I cant find anything.
    Any ideas?

    EDIT: Now I've looked a Rob's version in Sketchup, I can see exactly what was causing the issue. Cheers
     
    Last edited: Nov 10, 2012
  20. JACANT
    JACANT Well-Known Member
    You can use Netfabb and Meshlab in OSX. Only meshlab in MacOSX is (intel only)
    http://www.netfabb.com/download.php
    http://meshlab.sourceforge.net/
    When I imported the file in Netfabb it was too small. I scaled by 25.4. I think Sketchup exports as inches. So to get it back into sketchup divide by 25.4.
    Meshlab will read and export in a number of formats.
    import:pLY, STL, OFF, OBJ, 3DS, COLLADA, PTX, V3D, PTS, APTS, XYZ, GTS, TRI, ASC, X3D, X3DV, VRML, ALN
    export:pLY, STL, OFF, OBJ, 3DS, COLLADA, VRML, DXF, GTS, U3D, IDTF, X3D
     
    Last edited: Nov 10, 2012