Strange issue with part dimensions

Discussion in 'Bug Reporting' started by Aprone, Feb 11, 2013.

  1. Aprone
    Aprone New Member
    First off, forgive me if this has been explained elsewhere (I have looked but didn't find this same situation in other posts).

    I've been slowly uploading different parts from my project to get an updated idea of how much this is going to cost me when it's time to print the thing. Yesterday my upload reported that it was too small to print, which is incredibly odd because the piece I added to the scene was the largest part so far. After doing several uploads to test different things, I discovered that Shapeways is changing the size of that one particular gear. When uploaded by itself it shows up over 4 times its actual size yet when I scale it down it believes it is several times smaller than what I'd expect from the scaling. It's very strange.

    What confuses me most is that everything I've checked in 3DS max says that the part is the same size (same dimensions) as the other parts around it. When I export this gear along with other parts, Shapeways scales all of the parts to match this gear. I've been trying it over and over hoping it will eventually do this process in reverse and scale the gear to fit with the other objects in the scene instead.

    I can guess and check with scaling to get the gear to print at the correct size, but I worry it won't be perfect and will no longer mesh with the other parts that all upload as they should.

    Any advice or ideas would be appreciated. Thanks in advance!
    - Aprone
  2. mkroeker
    mkroeker Well-Known Member
    Which file format are you using for upload ? Can you check your exported parts with netfabb studio basic
    to make sure their dimensions are correct ? It seems unlikely that shapeways is treating individual parts differently -
    perhaps there is some problem with the hierarchy of the objects in your software that makes the gear "inherit"
    a scaling transformation from some other part only if they are exported together ?
  3. Aprone
    Aprone New Member
    I'm using STL as the format. I haven't checked the dimensions with netfabb studio basic, so I'll have to try that later, but the dimensions and volume are all correct within 3Ds Max. I've double checked and this part has no inheritance with other parts, in fact, many of the other parts DO have inheritance with each other so I removed that thinking the crazy gear might be scaling correctly and the others are all wrong (but showing up as the size I expect by sheer coincidence). No luck on that though.

    Thanks for the netfabb tip! I'll continue to mess around with it. If I can't figure it out I'll post on here again, to seek help.
  4. Dan_E
    Dan_E New Member
    I'm having the same problem. I've only tried to upload one part so far and every time I try to upload it, it's over twice the original size. I'm using Inventor 2012 and exporting the files as .stl
    Does anyone know of a setting I might need to change in Inventor that could be scaling it up?
    Last edited: Mar 12, 2013