Still having sizing issues

Discussion in 'Software and Applications' started by Helkat, Aug 9, 2012.

  1. Helkat
    Helkat New Member
    Hello everyone, thanks for reading my post.

    i am still having sizing issues when exporting from 3ds max 11 to shapeways. I have tried cm, mm, and inches. I am making sure my upload selection matches the selection I am working in. I have changed both Customize->Units Setup and System Unit Setup. I also tried downloading the calculator, and it won't work. I have tried using both OBJ and STL files, still no luck.

    Does anyone have any other ideas I could try? Thanks in advance.
  2. virtox
    virtox Active Member Moderator
    Can you describe your problem in more detail?

    What size are you intending?
    What does the calculator say?
    What does the site say?


  3. Helkat
    Helkat New Member
    When I try to run the calculator I get a MAXScript FileIn Exception error that says:

    -- Syntax error: at keyword parameter, expected name
    -- In line: HyperLink txMaterialInfo mainLink address:m

    For Units setup, I currently have US Standard Decimal inches selected, and for System Unit Scale, I have 1 Unit = 1 inches.

    I am trying to make a basic bangle, to sort of just get started and get my bearings. I want it to have an inner diameter of 2.75 inch, an outer of 3.5, and a height of 0.75.

    In the parameters for the tube, which is the primitive I'm using, I have entered these measurements. However, when I go to utilities, and press measure, the x dimension is 6.894, the Y is 7, and the z is 0.75.

    After uploading the STL to the site, (and selecting inches), I get..... in: 6.9 w x 7 d x 0.7 h

  4. virtox
    virtox Active Member Moderator
    Hmm, will check on the error for the calculator.

    As for the size, for a tube you need radia which are the diameter/2.0.

    Last edited: Aug 9, 2012
  5. Helkat
    Helkat New Member
    Also, for that calculator error, it brings up the code and jumps to line 1127.
  6. Helkat
    Helkat New Member
    Derp. I was wondering why the height seemed to stay consistent, but the rest did not....

  7. virtox
    virtox Active Member Moderator
    I am puzzled as to why the error would occur, and maxscript debugging is not always helpful..

    Could you try to change line 1140 (i think)
    HyperLink txtMaterialInfo mainLink address:mainLink color:(color 127 127 255) hovercolor:(color 255 0 0) visitedcolor:(color 0 0 192) align:#left offset:[10,0]

    with this:
    HyperLink txtMaterialInfo "" address:"" color:(color 127 127 255) hovercolor:(color 255 0 0) visitedcolor:(color 0 0 192) align:#left offset:[10,0]

    And see what that does for the error?
  8. Helkat
    Helkat New Member
    line 1140 looks like notes. It's line 1127. And that seemed to fix it. :>

    I feel so silly for the radius/diameter thing. I reuploaded, and that fixed the issue. -_- I have been trying to figure this out for an entire week. I think I've had my blonde moment for the remainder of the year. :blush:

    Thank you so much for your help!!! :D