Sizing in Maya

Discussion in 'Design and Modeling' started by Quadraxis86, Jul 5, 2014.

  1. Quadraxis86
    Quadraxis86 New Member
    I'm making a small hairclip in Maya and I'd like the dimensions to be around 3cm by 3cm by 0.6cm. I was using the distance tool within Maya to check the dimensions but it seems to upload to a smaller scale in Shapeway. I've checked my units in the settings in Maya which are in Millimeters, but when my model is around 30mm in Maya, it sizes down to about 20mm in Shapeway. Does anyone know a reliable method for measuring in Maya?
     
  2. samfleming
    samfleming New Member
    Have you confirmed that your measurement is broken in maya - and the sizing is just not being lost in translation when moving between files/formats or the shapeways services? LIkely your measurements are accurate within maya, its just getting butchered in conversion along the way.

    Try exporting the file to another app to verify the size. You could export an STL and import that in a free app like openscad for instance.

    You might also try running your file through a cleanup tool such as http://netfabb.azurewebsites.net before uploading it to shapeways.

    Sam Fleming
    http://www.thelostpiece.com
    $40 Flat Fee 3D Design Service


     
  3. mkroeker
    mkroeker Well-Known Member
    Size errors with exports from Maya have been reported several times, though it is normally off by a factor of 10 apparently. (Suggesting that Maya may be using centimeters as its export units no matter what). Get netfabb studio basic (freeware) from netfabb.com to check and resize your models before uploading - this is as close to what shapeways uses internally as you can get.
     
  4. Quadraxis86
    Quadraxis86 New Member
    Netfabb works great for sizing, but now its made a change of its own to my model. I have absolutely no clue how to fix it. I can upload a picture if needed. It's deleted a few of the necessary faces from a support piece, leaving a hole in the model.
     
  5. mkroeker
    mkroeker Well-Known Member
    Probably needs a picture to see what really happened, especially if you think that netfabb modified your model on its own , without you selecting "repair" first. How much did you have to resize your model (thinking if it is possible that the missing faces were not attached to the rest of the model, so were not
    resized with it and are now sitting somewhere inside, or in another corner of the world coordinate system) ?
     
  6. Quadraxis86
    Quadraxis86 New Member
    Here's two pics of the model, one in Maya and one in Netfabb. I exported the Maya file to an OBJ into Netfabb. The broken section looks the exact same before and after the repair feature in Netfabb. I have tried exporting it into 3ds Max, but I still get the same results when putting it into Shapeways.
     

    Attached Files:

  7. mkroeker
    mkroeker Well-Known Member
    Can you get Maya to display surface normals for that patch (or even just wireframe to see if it is really a single closed surface or a crisscross of overlapping polygons that is glossed over by shading) ? Or try a different output format - stl for example - in case there is a problem with the obj export
    function.