Shapeways WIDGET

Discussion in 'Shapeways Shops' started by universaljointNU, Dec 25, 2010.

  1. universaljointNU
    universaljointNU New Member
    I'm not getting the widget to work on a Wordpress blog. Do I need to do anything other than replace "YOURSHOPNAME" with the name of my shop?

    Am I correct in thinking that the name of my shop is just the part after the backslash in the url for my shop?

    http://www.shapeways.com/shops/my_shop_name
    <iframe frameborder="0" style=" border:1px solid #c0c0c0; height:182px; width:628px;" src=" http://www.shapeways.com/widget/include.php?shop=YOURSHOPNAM E&shopcat=SHOPSECTIONNAME&style=light"></iframe>

    Merry XMas and Thanks for any tips with this.
     
  2. virtox
    virtox Active Member Moderator
    If you don't have shop sections (yet) you should probably remove the &shopcat=SHOPSECTIONNAME ;)
    If you want to use a specific section, fill that in of course
    (contrary to the name it selects sections which you can define in the edit shop page, it does not work with categories think).

    You can experiment with the url in your browser to check what you get from the Shapeways server is what you want:

    http://www.shapeways.com/widget/include.php?shop=universaljo intdesign&style=light

    There are some problems in wordpress and the visual editor with iframes.
    Entering it In html mode it should work ok.

    Otherwise you might try this:

    Install the Embed Iframe plugin by Deskera (through the wordpress interface)
    That works with this code :

    Code:
    [iframe http://www.shapeways.com/widget/include.php?shop=universaljo intdesign&style=light&rows=2&cols=4 628 128] 
    
    Cheers!

    Stijn
     
    Last edited: Dec 25, 2010
  3. universaljointNU
    universaljointNU New Member
    Hi Stijn.

    Thanks a bunch. I'd really love to get this working.

    This is the text I entered and I think I followed your instructions. Does it look right to you? It is not working. Just the code comes up.

    <iframe frameborder="0" style=" border:1px solid #c0c0c0; height:182px; width:628px;" src=" http://www.shapeways.com/widget/include.php?shop=universaljo intdesign&style=light"></iframe>


    I then tried just the text below but I think this is not what you were indicating. Again just the code comes up.

    http://www.shapeways.com/widget/include.php?shop=universaljo intdesign&style=light

    >There are some problems in wordpress and the visual editor with iframes.
    Entering it In html mode it should work ok.

    Can you tell me what you mean by entering in html mode? The only thing I have done is link a piece of text to a url so that you click on the text and go to the link in a new window. This code should behave differently, yes?

    ***

    > Otherwise you might try this:

    Install the Embed Iframe plugin by Deskera (through the wordpress interface)
    That works with this code :

    [iframe http://www.shapeways.com/widget/include.php?shop=universaljo intdesign&style=light&rows=2&cols=4 628 128]

    THANKS! I will try this now as well...

    - Jon
     
  4. universaljointNU
    universaljointNU New Member
    Hi!

    Thanks a ton. The plugin seems to be working.

    Can I ask you for a little more help on the formatting??

    It seems to want to show me 3 pages that I have to >> to. Each page shows 4 columns and 2 rows. It also shows me a scroll bar (horizontal and vertical) which makes things sort of confusing.

    http://formpig.com/blog/?page_id=2984

    Is there a way to show the models all in one Line so that you don't have to click on >> or <<?

    Thanks

    Jon
     
  5. universaljointNU
    universaljointNU New Member
    Hi. Fantastic.

    Thanks.

    Sorry for the multiple posts.

    Do you happen to know if there is a way to get the widget to show the /second/ line of text for the titles? The widget seems to be chopping off some of the second line of text and shows just a tiny bit which makes it look a little sloppy...

    Again a big thanks...

    - Jon
     
  6. bartv
    bartv New Member
    Hi guys,

    I figured it would be much easier if we supplied a WordPress plugin that handles this for you. I just released a first (beta) version, available from the WordPress Plugin Directory:

    http://wordpress.org/extend/plugins/shapeways-gallery/

    It can work in two ways:

    1. As a widget: just add the 'Shapeways Gallery Widget' to your theme and configure it inside WordPress (see the attached screenshot).

    2. Inside a post or page: just add a shortcode to your post with the required options. For example:

    [shapeways shop=bartv cols=4 rows=3 style=dark]

    The available options are:

    * shop - the name of your shop
    * shopsection - the name of a section in your shop (ignored if 'shop' hasn't been set).
    * fav - display the favorites of this username
    * cols, rows - the number of columns and rows in your widget.
    * style - allowed valued are 'light' and 'dark'. The default value is 'light'

    It would be great if you could test-drive it and give me feedback before we give this more publicity. If you need more features, let me know!

    Cheers,

    Bart
     

    Attached Files:

    Last edited: Dec 27, 2010
  7. formpig
    formpig New Member
    Hi Bart.

    Great. Thanks.

    I can try this if I get a little time over here.

    Can I please ask you if it would be markedly different than what is shown here?

    http://formpig.com/blog/?page_id=2984

    I guess it would give me the opportunity to get rid of the "lost" second lines that are partially showing up?

    Thanks,

    Jonathan
     
  8. bartv
    bartv New Member
    Yeah, I noticed that as well. I'll have to pass that issue along to the guys who made the widget - all I did was create a WordPress wrapper around it.

    Bart