Shapeways site update of October 7th 2010

Discussion in 'Official Announcements' started by arno, Oct 7, 2010.

  1. arno
    arno New Member
    Hi All,

    Today we have had another site-update. The changes applied today may be less noticeable for you but are a major improvement to our developers.
    We had no site update release in the last 2 weeks because of the major work that has been done. We have made a lot of changes in underlying architecture of the site and that cost more time to prepare and test.
    A lot of code has been rewritten without any functionality or layout changes for perspective to the user, but these rewrites will make future development a lot easier.
    Because of the major changes, also the update today took a bit longer as usual. Sorry for the inconvenience.

    Additional to the architectural rewrites, the following features are introduced:

    Register for newsletter on signup page
    Users are be able to immediately sign up for our newsletter on the sign up page for a Shapeways account.

    Expand search box onclick
    Clicking the search field for the google site search makes the search field larger.

    Also we applied fixes for the following issues:[list type=disc]
    [*] Deleting the last category for a product on the product details page was not possible for users
    [*] The 3D viewer was not working for hidden files on the product details page.
    [*] When you had a quote in the title, description or tag on the model upload form, the quote was doubled when you looked at the model details page.
    [*] Shop logo's are too wide for right column
    [/list]

    Kind regards, Arno
     
  2. KSND
    KSND New Member
    I'm suddenly having a problem uploading models, with shapeways ignoring my selected scale and always using meters. Anyone else having this issue? Something to do with the update?
     
  3. LostInBrittany
    LostInBrittany New Member
    I have the same problem, everything is uploaded in meters... so my designs are refused because they measure 32 m... :(
     
  4. baltimore
    baltimore New Member
    yes I have this issue too. I had to scale my model down super tiny in autocad and then export it. I was doing everything right, and as usualy designing in mm, exporting the stl, and uploding the stl to shapeways using the mm button.

    as a temporary fix i scaled my object down 1000 times in autocad and then it worked with shapeways, but its definitely a problem on shapeways's side
     
  5. KSND
    KSND New Member
    Thanks for the responses, guys, I was wondering if I'd lost my mind or something, because I was SURE I wasn't doing anything different.
     
  6. robert
    robert New Member
    Thanks for all the feedback and sorry for the inconvenience. We are working on a fix.

    - Robert
     
  7. barrys
    barrys Shapeways Employee Dev Team
    Hi KSND,

    are you sure you didn't saved your part in inches?

    I looked at the last version of
    'JagerMech for Stereolithography Posed (1 285th, in).stl' in minimagics (2.0) and got a warning at opening that your part is very small and might be in inches instead of mm.
    If I can convert it then to mm it uploads fine.

    If I take that original last version file and upload it in inches it also uploads fine.


    If thats not the case, please send me the file so I can take a look at it to see what's going on:
    barry@shapeways.com


    I also tried a model file of my own that I uploaded before the release in mm, and now after the release it still uploads ok in mm.

    Barry
     
  8. KSND
    KSND New Member
    Barry,

    My part is saved in inches, the problem is that when I select "inches," it's getting upsized. I keep getting the message that my model is too large: "The size is 144.00 x 118.75 x 177.95 cm / 56.69 x 46.75 x 70.06 inch."

    So the model is supposed to be 1.77 inches tall, but it's coming out to 1.77 meters tall even though I'm selecting inches on the upload screen. It worked yesterday for my last successful upload, and the only difference between that version and the one I'm trying to upload now is a minor variation on the pose.
     
  9. LostInBrittany
    LostInBrittany New Member
    I have the same problem. My model is saved in "Blender units", that translates to mm when I export to STL in Shapeways. It has worked like that untils this afternoon, when even if I click on mm, they seems to upload in meters.

    EDIT : I've tried again just now, and it seems to work :) :)
     
    Last edited: Oct 7, 2010
  10. KSND
    KSND New Member
    Glad mm is working, still not working for me with inches =/

    I'll try mm in a bit.


    EDIT: mm still doesn't work for me, I have to use full meters
     
    Last edited: Oct 7, 2010
  11. THE1REBEL
    THE1REBEL New Member
    Same problem here. :cry: Glad I looked at the forums before freaking out.. :D
     
  12. LostInBrittany
    LostInBrittany New Member
    Yesterday it seemed to work once, I could update one of my models.

    Today I've tried to update another (in mm) and I have got the same error (it went in meters).

     
  13. barrys
    barrys Shapeways Employee Dev Team
    The problem was with the update model form instead of the normal upload form. It indeed did not take the scale factor.

    It's fixed now.

    Barry
     
  14. dizingof
    dizingof New Member
  15. KSND
    KSND New Member
    Thanks, Barry, seems to be working now.
     
  16. dizingof
    dizingof New Member
  17. barrys
    barrys Shapeways Employee Dev Team
    1.
    You don't see the markup for your own products in the price, because you don't pay markup when you buy your own model. If you log out, you can see the price has increased with the markup.

    I can see the model cost $10.18 now, which seems incl markup.

    2.
    The full color sandstone isnt available because your model is not a color model. Then sandstone should be available, but that was selected on the restriction list.

     
  18. barrys
    barrys Shapeways Employee Dev Team
    It could have been that the server was a little busy and had some delay in updating the price to be visible.
    It does show correctly now as $33.


    The last few hours, the server was very busy again and some model uploads/price cache updates could have some delay. We are working to minimize that delay.
     
  19. dizingof
    dizingof New Member
    Last edited: Oct 11, 2010
  20. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Because it's listed as jewelry.