Shapeways site update of December 1st 2010

Discussion in 'Official Announcements' started by barrys, Dec 1, 2010.

  1. barrys
    barrys Shapeways Employee Dev Team
    Hi all,

    we had site update today that took a bit longer than usual, but all went well eventually.
    We released the following features/bugfixes:

    Fixed hanging default properties in creators We had the problem that the default text in the creators wouldn't change on some operating systems with the latest java version update and therefore couldnt order or save a creator. This is now fixed finally.

    Store sorting directions The sorting directions like picerange from 'low to high' is now stored for every gallery you last visited.

    The 3D viewer popup did not appear when a model wasn't printable.

    It wasn't always clear that when you want to become a business user and already had a shop you have to contact customer support, so we added a text to inform the user when you try that.

    Best regards,
  2. virtox
    virtox Active Member Moderator
    I do seem to be suffering from a glitch in the model pipeline..

    This afternoon I updated an existing model with a zipped 500k stl.
    The page showed the "is processing" a long time. (500k takes a while ;))
    Only got one email. (thanks for uploading)
    When the message was gone, the model had not been updated, the version is still zero. And the volume also shows old values.

    In the mean time I had uploaded two new low-poly stl's which went through instantly.

    I have now uploaded two 500k stl files, unzipped, but as yet nothing to see.

    Also tried the update again : 834
    Still processing too.
    The update has worked this time., but the earlier uploaded 500k models have not made ti through yet.

    I'm assuming there are multiple upload pipelines?
    As they seem to overtake each other sometimes?



    Last edited: Dec 1, 2010
  3. Magic
    Magic Well-Known Member
    Same thing here. My update is stuck...
    I have the message:
    for more than 30 min now...
    My model is not very big though...
  4. virtox
    virtox Active Member Moderator
    Ok, things seem to be trickling through, after 3 hours one of the models made it. So I assume the second one will too, eventually.

    The first model update took more than 6 hours, I assume the second attempt at update is still being checked..

    So I guess it's just a busy upload day?

    Could be useful if there were some sort of indicator on site, how busy the upload queue is?

    Last edited: Dec 1, 2010
  5. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I've noticed that it's fairly common for things to get backed up after updates. Probably working through the que up back log until it's up to full speed again.
  6. Magic
    Magic Well-Known Member
    I took 3 hours for me too: but the update eventually occured.
    I guess the updates are slowed down by all the people trying to do the 10,000th upload, right? :D
  7. barrys
    barrys Shapeways Employee Dev Team
    I looked into this, but seems it was not update related but simply a few models in the queue that cost a lot of calculation time. This could occur at any time.

    We're looking into this to improve the upload time.
  8. virtox
    virtox Active Member Moderator
    Ok, thanks and sorry for the false alarm, I was in a hurry for a customer order..
    And I got a bit confused because the order of model approval got shuffled.

    Also, the (updated) model page gave a premature indication it was done (processing message disappeered several hours before I got the final "ok" email)

    Me uploading several 500k models at the same time,
    probably did not help with the queue speed :rolleyes:

    Still, some sort of queue monitor/message would seem ideal,
    "50 models before yours, please hold" :)

    Perhaps just a few color codes : ( since the USA won't be using them anymore :p)
    red(very busy)


  9. GHP
    GHP New Member

    I'm now getting the error message "An unknown error occured" when I try to view "My Designs". I can still view them through my shop, however.

  10. WelshDesigns
    WelshDesigns New Member
    same here, I did an upload, and got e-mail things are fine, but I can't access "my designs" page at all to edit it or see any of my store really.
  11. barrys
    barrys Shapeways Employee Dev Team
    There were problems with the galleries and model uploads last night after a server reboot.
    This has been fixed and we're up and running again.

    All models that were uploaded during that time are still in the queue and are now being processed.
  12. dizingof
    dizingof New Member
    Slow processing for me too... and the model is only 16k polygons..

  13. Grimjier
    Grimjier New Member
    3d viewer on a model I uploaded shows it missing parts, yet same file viewed in other programs shows up fine. Glitch related to this fix? Don't want to order a part that may come out screwy.
  14. dizingof
    dizingof New Member
    Still very slow validation process...
  15. GHP
    GHP New Member
    @Grimjier: If your model was non-manifold at all or had overlapping meshes that needed to be unified, Shapeways' MeshMedic will have tried to fix this for you automatically. It's possible that something got lost in the process. You may want to contact service at Shapeways about this.
  16. hans_lambermont
    hans_lambermont Shapeways Employee Dev Team
    Hi Dizingof,

    Your model 188158 took no less than 3681 seconds to process. Our new self-Intersection check was responsible for 3394 of those seconds.

    Model 188406 took 658 seconds to process.

    Model 188501 took 57 seconds to process.

    So it's our new self-Intersection check causing these long delays. We'll work on this.

    Hans Lambermont
  17. dizingof
    dizingof New Member
    Great. Thanks.