Shapeways glitch, or just my files?

Discussion in 'Bug Reporting' started by TreadshotA1, Dec 26, 2010.

  1. TreadshotA1
    TreadshotA1 New Member
    Hmm, just wondering if any other modellers here have had this problem.

    I use Sketchup to make all my 3D models, as it is a free platform and i find it easy to use for most cases. Now, to save costs, i like to combine my models into one file, to save on teh startup fee per model Shapeways charges. However, it seems whenver i import anything into my Sketchup file, and then export it as a Collada file, it fails.

    For example, i have a model uploaded here by the name off "Basic Gun with Bayonet" (or something like that). It has two cylindrical barrels touching each other, so is non-manifold, but uploads just fine as a collada file. I then take another sketchup window, and import 2 of these guns. The file again is exported as a collada file, but fails to upload, saying "the model could not be validated". The error explanation given is that the "dialect of STL is not recognised" It tells me 9 times out of 10, Meshlab fixes the issue. I have meshlab, tried it, it doesn't work. Plus, why does it say my STL dialect is not working, when i'm using a COLLADA file? I've had this issue with some other models too, the only thing they have in common is that all involved importing existing models.

    I have tried everything, exploding all components, and nothing works. The only way i can upload is to either draw everything again from scratch (which takes too long for most models), or change it to an STL file, which Sketchup can't export as. So, i have to have someone here do it for me, which is very iconvenient and sometimes ruins the scale.

    So, has anyone else had this problem? Is it a glitch with the upload, or just me?
    Last edited: Dec 26, 2010
  2. dizingof
    dizingof New Member
    Sketchup is great... but without the free plugins & rubi scripts you wont be able to make much..

    So, here is a good resource for free plugins and Ruby scripts for Sketchup : 909

    As for your issue .. its simple - install the free STL import/export plugin and you wont need to deal with collada anymore.