Search Engine failure?

Discussion in 'Bug Reporting' started by bavarian_arts_and_crafts, Oct 16, 2013.

  1. Hi *,

    I've got a strange problem here:

    A model in my shop, perma-link:

    When I use the search form to look for 'expensive', 'billion', 'dollar', 'coin' (or combinations of these words), my model is not found/ displayed. It has been uploaded a couple of days ago, so switching the result order to 'Newest' should bring it up near the top on longer result lists.

    Can somebody please enlighten me what is going wrong here?

    kind regards,

  2. AmLachDesigns
    AmLachDesigns Well-Known Member
    The Shapeways search engine does not work - it has been discussed many times in the Forums.Keywords do work up to a point - have you set them up?
  3. Hi AmLachDesigns,

    I would not state that the search does not work at all, when looking for 'hidden compartment', it comes up with , that is correct.
    My other stuff is found, too (tried 'grappling hook', 'mesh' or 'soccero'). Only that coin is troublesome (so far).

    I will try some keywords/ tags until this is fixed.

    thanks for your help,

  4. bartv
    bartv New Member
    Hmm, sorry to hear that. I'll forward this issue to our search engine developer!
  5. AmLachDesigns
    AmLachDesigns Well-Known Member
    Well, I must apologise - I see that changes have been made, and it seems to work a little better now. In my defence this was previously much discussed in the forums and I have no idea when this change was made as no posting was made in those discussions to my knowledge - was it announced?

    Having said that, for example when I search for Letzebuerg only some of the models with this as a Tag come up. Apparently 'Letzebuerg' is not equal to 'Lëtzebuerg'. So anyone using accents and special characters, time to double up on those oh-so-easy-to-maintain Tags...
  6. equilux
    equilux New Member
    I'm interested in models of a particular scale. Previously searching for a scale, e.g. "1:148", brought up only models of interest but I now get 10000+ results. If I search for "1/148" I still get the results I expect.

    I'd quite like both search terms to return the same results.

  7. Hi Bart,

    any new information from the developer?

    I uploaded a second version with similar description, and this one works and is found ( ).

    So I still think your database/ search index is messed up somehow. If a module of your shop system is somehow generating 'crap' data, the more data you have the more 'crap' you'll get.
    And since such problems propagate and tend to get bigger, not smaller, I suggest you try to fix this ASAP.

    kind regards,
  8. bartv
    bartv New Member
    Hmm, that IS odd. I'll forward both cases to her and ask her to check it out. I agree, something's not right here and needs to be fixed.

  9. <another week gone by, still not working>
  10. bartv
    bartv New Member
    I know, all our devs are scrambling right now to get some other things in order for the holiday sales. I know it's a big nuisance, but this may take a few more weeks :-/
  11. seems it was easier than expected, I think it's working now :)
  12. bartv
    bartv New Member
    Well how about that. I guess someone had some spare time :) Glad to see this was fixed!