Scaling (SketchUp) vrml files

Discussion in 'Software and Applications' started by jimfoltz, Mar 10, 2010.

  1. jimfoltz
    jimfoltz New Member
    Instead of loading the .wrl file in Meshlab to scale it, I found I could add a line to the .wrl file to scale it.

    This is the top few lines of the SketchUp vrml export:


    #VRML V2.0 utf8
    Transform {
    rotation 1 0 0 -1.570796
    children [
    Shape {


    I just add a 'scale' line after the rotation:


    #VRML V2.0 utf8
    Transform {
    rotation 1 0 0 -1.570796
    scale 0.0254 0.0254 0.0254
    children [
    Shape {


    SketchUp uses inches as it's internal unit. Shapeways uses meters as its default unit. So this line produces the model in the correct scale.

     
  2. jimfoltz
    jimfoltz New Member
    Need to update this...


    The Transformation is only in the .wrl file if the "Use VRML Standard Orientation" option has been used.