scale model with sketchup

Discussion in 'Design and Modeling' started by studiowootwoot, Mar 15, 2011.

  1. studiowootwoot
    studiowootwoot New Member

    i'm trying to upload a model i've made in sketchup.
    i've tried to scale it to 1/50 so it would be 9 x 9 cm, but i still get an error that the model is to big.
    So the model i see in sketchup is not the same size when i upload it.

    The only way to export it from sketchup is as an .dae

    Can anyone help me?


  2. bluelinegecko
    bluelinegecko Well-Known Member
    I've used sketchup for almost all the designs I've had printed up. One thing you want to look at is if your model contains any "grouped" items or components. If it does then you need to "explode" all of them AFTER you scale the model to the right size.For some reason they will still read their initial size and not the size they appear on screen if you don't explode them. I'm using sketchup8 and it works great for me without having to use any other software to convert the majority of my models.
    Last edited: Mar 16, 2011
  3. studiowootwoot
    studiowootwoot New Member

    thanks for the answer.
    I've tried the things you've said, but i still get an error, now the error is "empty output".
    I've made a simple 3d in sketchup just by pulling some surfaces. Is there a special way to make your models by sketchup?

  4. bluelinegecko
    bluelinegecko Well-Known Member
    I've made several models through sketchup but have never gotten that error yet. Are you using version 8?

    Aside from the scaling issue I mentioned earlier I haven't had any problems. I just design in sketchup, export as a DAE file and upload it to shapeways. Everything works great. I downloaded meshlab but haven't ever had a need to do the STL conversion process they describe in the tutorial here rt_to_stl_tutorial

    If you are going for a full color sandstone print theres a few more steps and you have to export to other programs, but for anything else this has worked great for me.

    you might want to set your export options like they show on this tutorial as well and see if that works.

    Can you upload a pic of your model? if all else fails I wouldn't mind taking a look at it and seeing if I could figure out whats going on with it for you.
  5. noesis
    noesis New Member
    Hi, I've used sketchup quite a few times too, everything @bluelinegecko is saying sounds like good advice, I just wanted to throw in my workflow for reference, because I've had similar scaling issues.

    Here's what I do:

    Model everything scaled up (I like to work in meters and pretend they're millimeters)

    When finished I save the file, then I open up the group or component of the object and use the measuring tape tool to take a measurement of a know distance, i.e. 3 meters, then before I do anything else I type in 3mm, sketchup asks if I want to rescale the active group, I say yes, it scales it.

    Next I exit the group and move it to the origin point, most times I then explode the group down to bare lines.

    Finally I export to .dae and upload to Shapeways

    After all of that I just undo back to before I scaled the group and resave, so I can come back later and work on the model at the larger scale if needed, but my export model is at the correct size.

    The process seems tedious but you get it down pretty fast. Works like a charm for me, haven't had any issues since I started doing it this way. I avoid the actual scale tool like the plague, if I use it to scale then I always get size errors.

    Hope that helps!

  6. bluelinegecko
    bluelinegecko Well-Known Member
    Thanksfor a new tip Noesis, I wasn't aware you could use the measuring tape tool to scale like that. I'm going to have to give that a try. I occasionally get crashes scaling my models down ( I model at larger scale too) on models with small radius curves. I'll have to try your tip and see if it solves that problem for me too.
  7. andre77
    andre77 New Member
    A silly problem I had with sketchup was that i forgot to delete the flat model of the human that was in my default sketchup project.

    Kept on getting an error from shapeways saying my project was 66in tall.

    Delete the human!