Problem with the Java applet in Linux

Discussion in 'Bug Reporting' started by Lazza, Dec 7, 2010.

  1. Lazza
    Lazza New Member
    Hello everybody, I just discovered ShapeWays and it looks amazing. I wanted to try to create a customized lamp with the applet, but I get this error:
    andrea@andrea-laptop:~/Scrivania$ javaws shapeway.jnlp
    netx: Invalid jnlp file shapeway.jnlp

    Looks like the file format specification has been violated. Could you help me investigate this? I never had such problems with JNLPs before.
    Thank you in advance. :)
  2. esnoeijs
    esnoeijs New Member
    works for me. Running ubuntu 10.10 with sun Java SE RE 1.6.0_22

    By default you probably run one of the alternative java RE's, you could see if installing sun java will help, or try and run the jnlp with verbose option to see if it tells you anything useful about what is going wrong.
  3. Lazza
    Lazza New Member
    Of course I'm using OpenJDK since I don't want to keep 2 different versions of Java (and a proprietary one) on my system. It supports JNLP 1.0, 1.5 and 6.0 and it is VERY strict with the syntax validation.
    By the way I don't think keeping the jnlp compatible with version 1.0 would be so much panic.
    I tried to get netx say something more about the error but cannot find any way. :confused
  4. esnoeijs
    esnoeijs New Member
    I'm not sure how tech savvy you are, but you could try to edit the jnlp file and make some edits to see if it works.

    You should try changing the href attribute of the jnlp element to use "&" instead of "&"


    <jnlp spec="1.5+" codebase="" href="">

    <jnlp spec="1.5+" codebase="" href=";editor=1&amp;iep=abc123">
    The url will differ for different co-creators so copy pasting the above won't do you any good.

    This might very well fix the problem. Although do note that from personal experience the java applet might behave a bit buggy on linux. I used to have the problem where the applet would work just fine until I tried to quit it at which point it would hang.
    It's still very usable though.

  5. Lazza
    Lazza New Member
    Thank you. I'm not afraid of editing files... Here is the modified line:
    <jnlp spec="1.5+" codebase="" href=";editor=1&amp;iep=REMOVED">
    Do I miss something? It still doesn't work...
    Thanks again. :)
  6. dizingof
    dizingof New Member

    I don't want to open a new thread.. i too cant use the applet for sometime now , using the latest Firefox and i reinstalled Java but no luck.

    I get this error:

    Java Plug-in 1.6.0_20
    Using JRE version 1.6.0_20-b02 Java HotSpot(TM) Client VM

    exception: Cache must be enabled for nativelib or installer-desc support.
    BadFieldException[ Cache must be enabled for nativelib or installer-desc support, sr-231-1.x-webstart-current/jogl-natives-windows-i586.jar]
    at com.sun.javaws.jnl.XMLFormat.handleResourceElement(Unknown Source)
    at com.sun.javaws.jnl.XMLFormat.access$800(Unknown Source)
    at com.sun.javaws.jnl.XMLFormat$2$1.visitElement(Unknown Source)
    at com.sun.javaws.jnl.XMLUtils.visitChildrenElements(Unknown Source)
    at com.sun.javaws.jnl.XMLFormat$2.visitElement(Unknown Source)
    at com.sun.javaws.jnl.XMLUtils.visitElements(Unknown Source)
    at com.sun.javaws.jnl.XMLFormat.buildResourcesDesc(Unknown Source)
    at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)
    at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
    at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
    at com.sun.javaws.LaunchDownload.downloadExtensionsHelper(Unkno wn Source)
    at com.sun.javaws.LaunchDownload.downloadExtensions(Unknown Source)
    at sun.plugin2.applet.JNLP2Manager.prepareLaunchFile(Unknown Source)
    at sun.plugin2.applet.JNLP2Manager.loadJarFiles(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager$ n(Unknown Source)
    at Source)
    Exception: BadFieldException[ Cache must be enabled for nativelib or installer-desc support, sr-231-1.x-webstart-current/jogl-natives-windows-i586.jar]

    Any ideas?


    edit: ok fixed - cache was disabled on the java console found in the control panel directory.

    Last edited: Dec 11, 2010