Problem with STL from Solidworks

Discussion in 'Design and Modeling' started by jsp7707, May 11, 2010.

  1. jsp7707
    jsp7707 New Member
    Hello All,

    Attached is a zip file containing several stl files merged into 1 model. They are definately water tight individually, but when I merge layers in AccuTran I get all sort of errors.

    And I am having NORMAL issues as well.

    I also uploaded the individual pieces as well.

    These files were created in solidworks and then mated together in an assembly. It's where the parts mate that I'm having problems...
     

    Attached Files:

  2. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I'm a little confused as to how your joining them. Are you Boolean unioning them as solids?

    Looking in meshlabs I see the issue. You still have the surfaces in-between the pieces. You have to delete them out of there.
     
    Last edited: May 11, 2010
  3. jsp7707
    jsp7707 New Member
    Ahhhh, There in fact is the real question.

    Does Accutrans our MeshLab support boleen operations with multiple STL files?

    If not Is there a FREE program that does?

    Wow, I think I should post that.

    ... JEFF
     
  4. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    My software doesn't support Assemblies in STL apparently (opened fine in meshlab, in KC only one piece appeared), do you have them saved in SW format?
     
  5. bitstoatoms
    bitstoatoms Member
    Hi there,

    I have not downloaded the files to inspect them,

    But have you tried exporting the assembly from solidworks as a single STL file instead of as multiple STLs?

     
  6. ArMOO
    ArMOO New Member
    Hi Jsp,

    You made an interesting object. Upload the SW file, complete I'll see what i can do for you.

    Greetings AO
     
  7. jsp7707
    jsp7707 New Member
    I finally solved the assembly issue. Once all the parts were assembled I FIXXED them into position and deleted all the coincidences.

    I then went back into the part and shaved .00001" off of it.

    Then when I updated the assembly the parts weren't touching anymore.

    When it printed everything fused together anyway :)

    See Post:
    <a href="http://www.shapeways.com/forum/index.php?t=msg&th=2614&start=0&S=ceb03f20ba7526bf0c3338e0739e51d0" target="_blank"></a>