Polygons visible in printed part (Solidworks)

Discussion in 'Software and Applications' started by justice91423, Jun 11, 2013.

  1. justice91423
    justice91423 New Member
    This is my first 3d modeling project and I am completely self taught. So please excuse my ignorance as I try to explain the issue I'm having.

    I'm using solid works, and my parts have a lot of curved areas. I found that when I received my parts from Shapeways, the polygons were visible in the part. The attached photo shows the problem.

    Do I need to use more polygons somehow? If so, where in Solidworks would I control that?

    I'm really as a loss so any help is greatly appreciated.


    PS. I outputted the parts as .STL files, if that maters

    Attached Files:

  2. mkroeker
    mkroeker Well-Known Member
    Which version of SolidWorks ? Check if you have an "Options" button on the STL export dialog where you can
    influence the "subdivision" or "tesselation" of objects.
  3. justice91423
    justice91423 New Member
    Hi mkroeker

    Thanks so much for your help. I'm currently using Solidwoks 2013 SP0, but I was using 2010 when I originally made the part.

    I was not able to find the exact options you mentioned, but I did find the STL resolution sliders. Solidworks lists them as Deviation and Angle. I turned them both up to the max and saved the file that way.

    It was a big improvement, but I can still see lines (image attached).

    Is it possible there is a better file type for this?

    Thanks again for your help, and input is appreciated.

    Attached Files:

  4. Arnaud3D
    Arnaud3D New Member
  5. justice91423
    justice91423 New Member
    After monkeying around a bit I discovered something...

    What I had been doing to create the cone was I would draw a right triangle and then use Revolved Boss/Base to make the cone shape. This lead to an STL that appeared to have polygone lines on it (see example above).

    However if I created the cone by drawing a circle and using Extrude Bose/Base with a Draft (bringing it to a point) the STL appears smooth.

    Upon further investigation I discovered that the STL created with the Extrude tool had exactly twice as many triangles (2876 vs 1438).

    Obviously I have NO idea why this is, but there ya go.