Parts seem to be disappearing when exporting

Discussion in '3D Design Requests' started by TreadshotA1, Aug 15, 2011.

  1. TreadshotA1
    TreadshotA1 New Member
    Guess i just plain ran out of tricks this time around. I made a model in EasyToy, and then exported it as a (.obj) to Sketchup to finish some things. But now, when i export the model to Shapeways, part of it just disappears. I have no idea why this is happening, as the parts that disappear seem to be randomly dotted around the model.

    This is the model i see in Sketchup, seemingly fine:

    [​IMG]

    This is what Blender shows me:

    [​IMG]

    That's basically what i get when i upload to Shapeways. Shapes, but missing bits all over the place.

    I'd really appreciate if some who had some spare time could check this out for me. I've attached the .skp file as that's the only one i have that doesn't have bits disappearing all over the place. Please help? Thanks in advance to anyone who can help. :)

    EDIT: If it makes any difference, this is the reference pic i'm going by: http://tfwiki.net/w2/images2/a/a0/DNaviNeo1.jpg
     

    Attached Files:

    Last edited: Aug 15, 2011
  2. I just tried to take a look, but unfortunately your file won't open in my SketchUp at all. It complains of an "unexpected file type".
     
  3. TreadshotA1
    TreadshotA1 New Member
    Really? I just downloaded the file and opened that one, it only tells me that it's read only, but then opens as normal. Now i'm really worried.

    For the sake of making sure, i'll reattach the same file here, but i'm not sure if that'll help.
     

    Attached Files:

  4. TreadshotA1
    TreadshotA1 New Member
    Woops! It seems i managed to fix the problem myself. Apparently some vertices had been removed when i was exporting due to me...well, without revealing too many secrets, one of my plugins with which i'd drawn the system, the script behind it had a slight bug. I ran a second plugin and got it running perfectly fine in Blender and on Shapeways.

    Thanks for your help Ramrider. Always knew i could count on ya, bro. :)

    Mods, feel free to delete this thread now, it's no longer necessary.
     
    Last edited: Aug 15, 2011
  5. dynath
    dynath New Member
    Actually i'd like to know how you fixed this. I have basicly the same thing happening to me though i'm trying to resurface the file with the CADspan plugin for sketchup. but its the same parts just vanishing seemingly for no reason on export.
     
  6. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Have you tried opening the file in another program? Usually missing faces are due to inverted faces, or overlapping faces.
     
  7. TreadshotA1
    TreadshotA1 New Member
    Well, for me, it was a matter that I designed the actual character (the bug like thing) in one program, before exporting to Sketchup and designing it's stand. I made a lot of edits to the model in Sketchup, and everywhere I edited disappeared.

    So all I did was have the stand in a Sketchup file, and then import the bug-character, and instead of editing it, just scale it to fit the stand. The scaling doesn't seem to affect the model's integrity, so it worked. I just made sure not to touch the thing.

    I've since made a Version 2, which I did by exporting the file with both the DNAVI bug-thing, and the stand, into another program, and then editing it there. Everything worked fine.

    I think it's because the two programs I used/use now are both sculpting-based organic modelling programs, which have a lot of polygons, and Sketchup simply couldn't deal with so many polygons when I edited any part of it, causing some bits to disappear. By not editing the Bug inside Sketchup, only scaling it, Sketchup didn't have any issues.

    Moral of the story: if you import something with a lot of polygons into Sketchup 8, don't touch it.
     
  8. dynath
    dynath New Member
    Well my object has a lot of polygons as well but they were made in sketchup. Generally by combining a few hundred spheres/rectangles then using outershell. I tried a couple of times to use ST4SU or SUtoDXF/STL to export the original form but it never seems to work. Couldn't even open the resulting files in NetFabb. as I said CADspan produced a usable product for a while but has started making models disappear. I don't see any reversed faces and Solid Inspector gives me a pass. maybe its the polycount, CADspan might have an upper limit as well.