Objects not exported to STL

Discussion in 'Design and Modeling' started by bobbob12, Jul 26, 2010.

  1. bobbob12
    bobbob12 New Member
    I am using 3DMAX to generate my model
    six.jpg
    The model combined of only basic shapes as boxes and tubes.
    When exported, only about 4 boxes are exported and the rest of the objects just disappear like shown at .
    six_shapeways.jpg

    I tried to combine the objects, turn into mesh, attach, scale
    but nothing seems to be working

    Please et me know if you have seen anything like this before

    Thanks

    Udi
     
  2. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Have you opened in Meshlab? Inverted normals in files will cause transparency in Shapeways render. So they could be there, just inverted.
     
  3. bobbob12
    bobbob12 New Member
    Sorry, I am not familiar with Meshlab, can you let me know how can I get it?
     
  4. virtox
    virtox Active Member Moderator
  5. bobbob12
    bobbob12 New Member
    I tried Meshlabs and try to fix it in 3DMAX but still once imported to Shaeways the objects disappear.
    This model is built from the very basic shapes and with no boolean operation or anything like that, So I cannot figure out what is the problem.

    When imported to Meshlab, the STL looks OK

    Is there someone in the team I can send the STL file to to check it?
     
  6. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
  7. bobbob12
    bobbob12 New Member
    Thanks,
    I am attaching STL format and MAX format (V. 2009)
     

    Attached Files:

  8. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I'm not familiar with Max and how it works, but I can tell you there are issues in the STL. See the Image where there are many multiple faces overlapping. I'm seeing this in every intersection.
     

    Attached Files:

  9. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Alright, I think I got it to what you wanted. Upload this and see if that comes out better. When you built in max, did you build it as solids? did you boolean union the solids? That would be my guess as to why it came out the way it did. Because the solids weren't joined before export.
     

    Attached Files:

  10. bobbob12
    bobbob12 New Member
    Indeed it works.
    Thanks
    I would appreciate if you could tell me what went wrong, as I am now trying to upload another model, and again it wouldn't load.
    I am using simple solids, no boolean, just place one solid next to the other.
    The new model is even more simple as it use only one type of solid.
    The only thing I can think about that might cause the problem is the way I duplicate the solids, but I think the STL doesn't care about it.
     
  11. bobbob12
    bobbob12 New Member
  12. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    That is weird, by my measurements it should be longer than tall.
    Anyways, with your model, it appears when you exported, you had the solids overlapped. Instead of leaving them just overlapped, and letting shapeways try to automatically join them, Boolean Join them before exporting. When I exported, the piece is all one solid. That's why if you look at the stl, there are no overlapping faces. That was the only problem I saw with your model.
     
  13. bobbob12
    bobbob12 New Member
    I would like to try and print this model, but the Shapeways calculator calculate 34.71 cm³ while my 3DMAX finds 21.16 cm³
    As I understand the pricing policy, it is based upon the actual volume used in the model
     
  14. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Did you check the dimensions of mine? STL doesn't carry unit type. What ever units you used, I imported and exported back out. So check to see if it's still the size you want.
     
  15. bobbob12
    bobbob12 New Member
    The about size is the same, just the dimensions are mixed.
    But this is the boundries size, when calculating the volume, i think there is some mistake in calculation, as I am checking the model in 3DMAX and it shows ~20cm³ while in Shapeways I get 34 cm³