Non Manifold... but no non-manifold found in Blender

Discussion in 'Design and Modeling' started by tempusr27013_43fd9756e41, Sep 20, 2009.

  1. In the attached file, I cannot find a non-manifold area in the object Cube.003. I've exported it as x3d and attempted to upload it to shapeways twice. Each time I get an error back saying the object is non-manifold. Is the .blend --> .x3d format conversion causing it to be non-manifold?
     

    Attached Files:

  2. crsdfr
    crsdfr New Member
    Some of the bottom facing normals are around the wrong way :)

    normals.JPG
     
  3. How do I find the inverted normals and fix them? I couldn't find any 'inverted normals' tutorial on this site. I cannot identify any inverted normals in Blender (unless I'm doing something wrong, which is very likely).
     
  4. afrodri
    afrodri New Member
    I'd recommend checking out MiniMagics - its a free program which does a good job of finding inverted normals and non-manifold edges.
     
  5. Are you sure that MiniMagics still allows editing? I downloaded and installed the program and it refers me to "Magic RP" to do all my editing/fixing. Or should I use minimagics just for finding the problems and edit the objects in Blender.
     
    Last edited: Sep 21, 2009
  6. afrodri
    afrodri New Member
    MiniMagics doesn't do any fixing itself, but it does a good job of displaying where the inverted normals or bad edges are.
     
  7. Thanks guys! Minimagics is awesome!!!.. I wish they could build a Minimagics type script into Blender. Anyway, I got it fixed and uploaded, thanks!
     
  8. Tommy_2Tall
    Tommy_2Tall New Member
    Another useful tip:
    configure Blender to draw the face normals when editing the file.
    That way you can see them in blender and in this case you would probably have to load/import the x3d file and check the results as well.

    Go to Editing mode and open up the mesh editing buttons panel.
    In the Mesh Tools More section there's a button labeled "Draw normals". Make sure it's selected/active.
    The normals should point out from the "solid material area".

    I use it all the time to make sure that the model won't spaz out when/if I add the SubSurf modifier.
    (If you see a face normal where there should just be a face edge you have a face that is not visible to the eye but it effects the subsurf division quite clearly.. a common problem when a noob like me tries to extrude a face/edge and forgets to move it away from its original location)

    The "Draw Vnormals" button does the same for the vertice normals, which may or may not be useful...
     
    Last edited: Sep 24, 2009
  9. clintbellanger
    clintbellanger New Member
    (in Blender)

    With some meshes, the option "Recalculate Outside Normals" cleans up these flipped faces.

    Select the mesh, [tab] to enter Edit mode. Click the "Mesh" menu on the 3D viewport, then Normals -> Recalculate Outside.

    Doesn't work for all meshes, but manifold meshes should work most of the time.