No results in my models?

Discussion in 'Shapeways Shops' started by macouno, Aug 21, 2012.

  1. macouno
    macouno New Member

    Ok so I have a weird shop, full of old models that were generated on my own site and uploaded through the api. (there were aroudn 2600 of em).

    I've been deleting them bit by bit because I'd love to clean up my shop and use it as a normal one, and don't want to start a fresh account... sadly there's no select/delete all function... (might be an idea).

    The new system is definitely an improvement because it doesn't require a reload of the entire page... but I got this one after deleting maybe 200 models today.... (See the attached image).

    And at this point in time there are still 1670 products in my shop... so the page is definitely not correct? Error in the system perhaps? Or some automated way to stop me deleting more than a certain nr at a time???

    Attached Files:

  2. bdickason
    bdickason New Member
    Hi Macuono,

    This looks like one of those little lingering bugs in the attic of Shapeways that is so far off the beaten path that noone has yet experienced it :p

    I was able to reproduce this in my shop on our test environment - it seems that if you have over 1,000 models and delete a TON of models, the 'my models' interface just runs out.

    For the time being you can fix this by refreshing the page (please let me know if this does not work), and we probably won't get around to fixing this one for a while as we have some really high priority stuff on the todo list right now!

    Either way I've logged it for eventual fixing :)
  3. macouno
    macouno New Member

    Sorry, that wasn't it. I tried refreshing... also with ctrl + F5. I even tried opening the page in a completely different browser... still get exactly the same result.

    Disabling cache completely doesn't help either. So I'm afraid its not on my end. Maybe my account is tagged in the database?

    BTW... if it's just because there's so many models. Please feel free to remove all models in my shop/account that have either "ship" or "ring" in their names, that would actually help anyway... then there should be only a dozen left ;)
  4. bdickason
    bdickason New Member
    Argh! We'll look into this shortly.
  5. macouno
    macouno New Member
    eek... so eh... I have some new stuff to upload... and... still nothing in "my models"...

    Actually... I uploaded something just now... and eh... since there's no direct link the notification e-mail. I have no way to get to it to order a test print...

    I hope you guys don't have this issue too low on the priority list..

    UPDATE: Ah wait... I can get to my model through the notification e-mail after all. Still can't get to my models though.
    Last edited: Aug 28, 2012
  6. macouno
    macouno New Member
    Hey it works again! How cool!

    Did you guys fix the bug? Or... should I still be very careful about how much stuff I delete in one session? ;)
  7. macouno
    macouno New Member
    Got a related issue.

    This model has apparently been partially removed only:
    It's still in my shop... but the actual file/model/item can no longer be found.

    In this case... it doesn't have to be fixed... maybe one should look into how this could have happened... but for me... just remove it please ;)
  8. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    If it weren't for extreme users like you, these bugs would forever lay dormant!
  9. bdickason
    bdickason New Member
    We THINK we fixed it!! We tried deleting 1,000 items from our shop in 10 minutes, as we figured this was the most anyone could delete by hand. :p

    I'll look into the partial removal from your shop as well.
  10. macouno
    macouno New Member

    Good going... I'll go and test it right now ;)

    Thanks guys!
  11. macouno
    macouno New Member
    Ok... wow... that was an experience...

    I'm all clean... or my shop is now!

    Only one problem! This model still appears on "my models", but has no thumb and can not be removed (just like before):

    edit -> Wait.. another one just popped up:

    edit 2 -> Hmm a couple are even just still in my shop, but not in my models, see here (errors with the thumbs):

    Other than that... great, no problems! Time to get some new stuff in there!

    Thanks guys!

    EDIT 3 --> ALL FIXED NOW! Thanks heaps... I really appreciate the effort folks!
    Last edited: Sep 2, 2012