Need Help for Paleontology Project

Discussion in 'My Work In Progress' started by WacoMammoth, Jan 30, 2013.

  1. WacoMammoth
    WacoMammoth New Member
    ADDENDUM: I've attached the Collada file.

    Greetings! I'm a paleontologist at the Mammoth Site of Waco Texas. At the moment I'm working on using photogrammetry to create a 3D map of the bonebed. I've managed to capture one section of the bonebed at a reasonably high resolution, and I'd like to prototype it. The problem is that it seems to get screwed up when I upload it. Large sections at the 'lower' elevations of the model are missing. How can I fix this?

    Attached Files:

    Last edited: Jan 30, 2013
  2. mkroeker
    mkroeker Well-Known Member
    Surface normals pointing the wrong way, or intersecting pieces possibly.
    Download a free copy of netfabb studio basic and try its checking and repair
    functions. (Or make a sample file available so the resident mavens can see what
    is wrong with it )
  3. Tank3D
    Tank3D New Member
    the problem with large area scanners is that they often create a high number of artifacts in the 3d mesh. these will prevent those meshes from being usable in most practical applications in their raw form. they almost always need to be worked on. sad, but true.

    if the free app doenst work, you could probably find a 3d artist on here that can create a clean model fairly easily, with all the detail of the original scan.
    Last edited: Jan 30, 2013
  4. WacoMammoth
    WacoMammoth New Member
    OK, so having played with the free app afore mentioned, here's whats wrong:

    The strange deletion of the lower elevation of the model is the result of hole filling. My photogrammetry captured the shape of fossils excavated in bas-relief; its a single surface or membrane. It thus doesn't have sides, a bottom, or volume. Shapeways (and Netfabb) are treating the edges of the scanned area as the edges of a hole and is throwing up a plane through the scan that connects these edges. Everything above this plane is treated as a solid object and retained, everything that is below the plane is discarded.

    Learning is fun! But . . .

    Here's the problem. I really have no idea how to fix this. All I've got is AGI soft photoscan, Meshlab, and Netfabb. None of these programs seem to include a way to turn a single membrane into a solid object. I still need help! Any ideas?
  5. Tank3D
    Tank3D New Member
    i dont have anything to do at the moment. i can take a quick look.
    i'll let you know what i find.
  6. Tank3D
    Tank3D New Member
    right, as i suspected, there are a lot of issues with this mesh. that often happens with scanners.

    at the moment, the collada or DAE-file had several cameras in it and the mesh of the scanned area is broken up into 7 pieces. this more than likely causes the issues you encountered.

    i tried a quick fix, but this ended up creating ugly seams and left holes in the mesh. unfortunately my laptop is pretty old and, well, crappy. i cant really work on the file on it. i should be able to fix this on my workstation and get it ready for printing.

    i wont be at my workstation until after the weekend. but any decent 3d artist should be able to fix this pretty easily.
    Last edited: Feb 1, 2013