Model sizes incorrect?

Discussion in 'Bug Reporting' started by terrymisu, Jun 6, 2012.

  1. terrymisu
    terrymisu New Member
    I uploaded two sketches from AutoDesk Inventor 2013 that are designed in millimeters.

    I exported the files to STL format, and uploaded them to Shapeways selecting millimeters as my scale.

    My objects (both circular), which have a 50mm diameter show up as being a 0.5cm objects. This *should* be 5cm.

    The length, width, and height for both objects is off by a factor of 10 for both files.

    Is this a website bug, or is my sketch really going to come out a factor of 10 times smaller than it should when I print it?
     
  2. pfeifferstylez
    pfeifferstylez New Member
    As far as I know, Inventor offers "unit" as STL export setting since version 2011.

    Click "save copy as", and before you save the file, click "options"...



    (No problems with Inventor 2010 so far. ^^)

     
    Last edited: Jun 6, 2012
  3. stop4stuff
    stop4stuff Well-Known Member
    It's not a website bug, generally an error like this is as the result of the software not exporting the right units of measurement, in your case perhaps one native unit is one centimeter. Simple solution is to scale up by 10 times and upload again.
     
  4. terrymisu
    terrymisu New Member
    Aha...

    There is an "Options" button when you export STL files that lets you change the units for STL.

    By default, the units are in CM.

    My model is in MM, but it doesn't automatically detect that.

    I'll try exporting as MM and re-uploading.

    Thanks!