Model Not Publicly Available

Discussion in 'Bug Reporting' started by lensman, May 15, 2012.

  1. lensman
    lensman Well-Known Member
    EDIT - Just minutes after posting this all was back in order again... !


    You guys are killing me....

    Now, when I'm logged in and viewing my own models, every single model that is unchecked "Display to the Public" has a nice black sign with white lettering saying that "This model is no longer publicly available"

    Clicking on the model itself some will open up and show the model others just show an even bigger black sign.

    A real mess.... and on top of that the models that do appear STILL don't show the most recent model upload...

    Glenn
     
    Last edited: May 15, 2012
  2. natalia
    natalia New Member
    Hi Glenn,

    Can you be a bit more specific please? Where are the big black letters appearing? Are you seeing this in edit mode?

    If you are UNchecking 'Display to Public' you actually don't want it to be available, so I'm not clear as to why "This model is no longer publicly available" is confusing.

    I am just trying to replicate what you see so we can fix it...

    Thank you!
     
  3. natalia
    natalia New Member
    Great!

    I think with the new dynamically updating site, some changes do take a few minutes.
     
  4. lensman
    lensman Well-Known Member
    I wish I could replicate it! All I know is the "sign" was the standard one you use when you (Shapeways) take off a model for whatever reason, but there is still a link to it. I've seen it before on other people's stores. And, no, I wasn't doing ANYTHING to my store other than just looking at the models and checking a few things out then all of a sudden this happened. Within 10 or 15 minutes the problem just went away.

    Glenn
     
  5. stonysmith
    stonysmith Well-Known Member Moderator
    Sometimes, (on any site) when refreshing your browser, not all the CSS gets reloaded properly. I wonder if what you were seeing was caused by something similar.
     
  6. lensman
    lensman Well-Known Member
    Aha! - It happened again just minutes ago.
    And just to show you I'm not crazy (well, let's not discuss that!) I took a screenshot.

    And in the time it's taken me to paste this into photo-editing prog, save and locate this old thread and write this the models are still showing the same state. So, this is not a momentary glitch.

    Tada!

    screenshot.jpg
     
    Last edited: May 24, 2012
  7. natalia
    natalia New Member
    Hi Glenn,

    I just checked and it seems the models are loading fine. Could you confirm?

    If this happens again (3rd times a charm?) it's definitely not just a refresh glitch so we'll get bug fixers on it.

    Thank you for letting us know!

    Natalia
     
  8. lensman
    lensman Well-Known Member
    Haven't had the same problem for a while but will let you know if it happens again... now if we could just get the model upload refresh sorted out :confused
     
  9. lensman
    lensman Well-Known Member
    Okay, just had this happen to me again. Interestingly, though, two of the models are showing correctly, all the others are marked "not publicly available".

    This is not a momentary glitch, either. It goes on for many minutes.

    Also, if I click on an item on My Orders page I still get that same "not publicly available" image instead of the model thumbnail.

    Glenn
     
  10. natalia
    natalia New Member
    Glenn,

    We made some updates and changes to model inventory this past week - can you confirm if this is still happening?

    Or did it get fixed with last weeks release?

    Thank you!
     
  11. lensman
    lensman Well-Known Member
    I haven't seen this occur since my last message so figners crosed (not easy to type then :D )

     
  12. Dragoman
    Dragoman New Member
    It's still happening:

    screenshot.JPG

    Quite a nuisance! I only have a few non-public models, but if someboday has a lot of them...

    If Shapeways wants to mark models as non-public, you can do that by less obstructive means.

    Greetings
    Karl Heinz

     
  13. stonysmith
    stonysmith Well-Known Member Moderator
    Go to "My Shop" and then follow the link "View Public Shop"

    At least they seem to be displaying for customers:
    screencap.jpg
     
  14. natalia
    natalia New Member
    Hi Karl,

    I just had a look and it appears normal - can you confirm this?

    Often, as it was for some of the above posters, its a matter of refresh time.

    The message did used to say "Model uploading" with a pixelated blue image instead of "Model not publicly available" so as we improve the site, we are trying to bring that message back, as it is more accurate.

    Thanks!
    Natalia
     
  15. Tbmod
    Tbmod New Member
    I have two id's on shapeways this one which has mostly things for my own use and very few public models and Tebee which has most of my public facing models plus some that are commissions for other people.

    Now on this ID (tbmod)everything displays as normal but on the other ID(tebee) any model that is not displayed to the public is now showing the black "Model not publicly available" image.

    This is also affecting one of my customers who buys some of the private models and can no longer see what he is buying !

    Strangely enough I have spoken to one other customer who also has some private models and he does not have this problem.

    It would appear to be some sort of cookie problem as if I access my Tebee models logged on in a Chrome incognito window I see them all displayed as normal.

    Tom
     
  16. Dragoman
    Dragoman New Member
    Hello Natalia

    Right now, it looks good.

    I don't think it has anything to do with something I did. Some of the blacked-out models have been there for some time and I remeber having seen them

    Greetings
    Karl Heinz
     
  17. lensman
    lensman Well-Known Member
    Nope, definitely not an error that pops up with model uploading. Like others, I experienced this for no apparent reason and on at least one occasion it lasted for hours.

    Though, as I said before, I haven't seen this error since my last mention of it.

    Glenn
     
  18. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I had this problem this morning, and noticed something that may or may not be attributed. Normally I use Firefox's reload previous session every day as I did today. Which keeps me logged into the forums, but usually when I leave the forums it asks me to log in. I didn't see it this morning (nor did I notice it until later today when I tried to upload a model). So if you guys could check to see if 1) it has your user name in the top right, like it should if you're logged in, and 2) try going to another part of the site, like upload, that requires you to be logged in. If it does ask you to log in, log in, go back to your models and see if they are displayed properly. After it asking me to log in, and logging in, my images now show properly.

     
  19. WiKKiDWidgets
    WiKKiDWidgets New Member
    I'm getting this same thing all over my Models all the sudden. :cry:
     
  20. stop4stuff
    stop4stuff Well-Known Member
    I had the same this morning

    private models dont show.JPG

    So I followed Mike's advise (sort of) - I logged out, closed IE, which also clears cookies, opened IE, logged back into Shapeways and everything was back to normal.

    I'm guessing it's something to do with a session cookie as my internet connection flaked out whilst I was logged in, I reconnected before uploading a new model (without loggin out or in of Shapeways), and that's when the above occured.


     
    Last edited: Jul 4, 2012