Markup Reset On Image Order Change

Discussion in 'Bug Reporting' started by simzer, Mar 19, 2017.

  1. simzer
    simzer Member
    Hi, I have reproduced this bug with multiple times and different products:
    - have markup set on a product previously.
    - click on edit product
    - upload a new image
    - save
    - write 1 into image order box beside the new image
    Product gets saved automatically and all markup reseted to 0
     
  2. MitchellJetten
    MitchellJetten Shapeways Employee CS Team
    I've tried to reproduce this bug a few times but have been unable to get the same results
    Which browser and version are you using?

    It works fine here on Chrome.
     
  3. simzer
    simzer Member
    Hi, I'm using Firefox 52.0.1 (32-bit) on a Windows 8.1 (64-bit).
     
  4. MitchellJetten
    MitchellJetten Shapeways Employee CS Team
    I've reported it to our dev team as I've had no luck reproducing this bug :( (worked fine here in Firefox)
    I'll keep you posted
     
  5. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    @simzer can you provide an item you've experienced this with?
     
  6. simzer
    simzer Member
  7. NimlothCQ
    NimlothCQ Shapeways Employee Product Team
    Is this still happening? We released some fixes to product edit saving that may have been the actual root cause for this experience?
     
  8. cwant
    cwant New Member
    This has happened to me twice in the last 24 hours -- definitely an annoyance!
     
  9. cwant
    cwant New Member
    (I should mention, using Chrome on Linux.)
     
  10. simzer
    simzer Member
    Pressing enter after typing into the edit box seems to trigger the bug. So it can be avoided by removing the focus from the edit box by clicking somewhere else.
     
  11. cwant
    cwant New Member
    Yeah, it appears you can't press Enter anywhere on the page without it resetting all of the markups... (just happened again).

    :(
     
  12. DoctorOctoroc
    DoctorOctoroc Well-Known Member
    I've been having an issue with the markups on FUD and FXD specifically. I honestly can't say how or why it happens but generally, it's seemingly random. I'll add all my materials to a product while editing the details for the first time, set all the prices then click save. Then when I go back to edit the same product at a later date, the FUD and FXD prices are set back to the 'cost of print' price instead of the price I set. It happens with approximately 1 out of every 6 or 7 models I have uploaded in the last week or so.

    The only thing I can think of is with all of the changes going on with these materials lately, some info is not being preserved. Dunno though, not much of a programmer myself haha.