Markup matrix page has a serious problem

Discussion in 'Shapeways Shops' started by Oskar_van_Deventer, Jun 25, 2011.

  1. Oskar_van_Deventer
    Oskar_van_Deventer Well-Known Member
    Dear Shapeways,

    I know that many people have already complained bitterly about your markup matrix page, and I am aware that you have been working on this for a long time.

    Still, the problems remain severe. When I go to the markup page, it takes a full TEN MINUTES to load, if it loads at all (it fails 3 out of 4 times). It takes just 30 seconds to download all the pictures, but then the script starts spinning. My computer CPU goes to full load, with all the fans turning at maximum power to cool the processor. This goes on for ten minutes, without anything visibly happening. It is like a "while(true) do nothing" loop.

    You can understand how frustrating this is, as it impedes me to set my mark-ups.

    Would you be so kind and look again at your code, please?

    There must be a serious bug in your script.

    Thank you.

    Oskar
     
  2. mctrivia
    mctrivia New Member
    Yes many of us have been asking for an alternative like CSV which could allow us to quickly change in Excel then re upload. I see you have over 100 models. I personally can not open the markup page from my tablet as it kills the thing. I need to be on my quad core 3GHz computer. Which is ridiculous considering I do all my CAD work on my tablet this site should not need more processing then it takes to render the model in the first place.
     
  3. Oskar_van_Deventer
    Oskar_van_Deventer Well-Known Member
    This problem makes me wonder what the script is doing. Ten minutes of 100% CPU use could be good for
    -Calculating the billionth digit of pi
    -Making some high quality 3D renders
    -Earning 0.2 cents in a computer cloud
    -Searching for extra-terrestrial life
    but
    -Sorting 150 Shapeways models?

    Oskar