Manifold problems in VRML

Discussion in 'Software and Applications' started by EricvanStraaten, Jun 9, 2010.

  1. EricvanStraaten
    EricvanStraaten New Member
    There is something really strange with the online check. Here's what I found after much converting and uploading (all the conversions are taking in account that wrl and x3d work in meters):

    -Export of a manifold mesh to wrl and x3d in Magics 13 produces a nonmanifold mesh (according to Shapeways)

    -Export of a manifold mesh to wrl and x3d in Modo 4 produces a nonmanifold mesh (according to Shapeways)

    -Export of a manifold mesh to wrl and x3d in Meshlab (latest version) produces a nonmanifold mesh (according to Shapeways)

    -Export of a manifold mesh to wrl and x3d in Blender (latest version) produces a nonmanifold mesh (according to Shapeways)

    -Export of a manifold mesh to wrl and x3d in Netfabb (latest version) produces a nonmanifold mesh (according to Shapeways)


    -Export of a manifold mesh to wrl and x3d in ZBrush 3 produces a manifold mesh (according to Shapeways)!!!!

    So ergo: only Zbrush exports (with my somewhat intricate meshes) a printable model! How can it be that only this program does this?
     
    Last edited: Jun 10, 2010
  2. EricvanStraaten
    EricvanStraaten New Member
    I am sorry but I can't find the file wich I tested it with. I've tried to with a file again from ZBrush, but it comes back with a nonmanifold error. So I don't know what I did earlier and probably I'm mistaken, sorry for that! So it seems that all the processes mentioned don't work with my meshes. I've tried to do a test with a simple sphere, and this works flawless (with a x3d-export from modo).
     
  3. EricvanStraaten
    EricvanStraaten New Member
    Maybe someone could tell me what I'm doing wrong. Or is it just so that some models are just to 'complicated' to be conversed to vmrl?

    My workflow is as follows

    Modeling: DAZ3D (so usually this is a human figure)
    Obj to stl: Meshlab (merging close vertices)
    Cleaning stl: magics (closing holes leaving meshes intact)
    Stl to obj: Meshlab (merging close vertices)
    Modyfying: ZBrush (smoothing and such)
    Obj to stl: Meshlab (merging close vertices)
    Shrinkwrap stl: Magics
    Stl to obj: Meshlab (doing nothing except unify duplicate vertices)
    Obj to x3d: Modo (painting and rescaling a factor 1000)
     
  4. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Would you mind putting up a failing file for us to examine? Please keep your posts to one thread also.
     
  5. EricvanStraaten
    EricvanStraaten New Member
    Allright, I'll keep my posts in this thread. :blush:

    Attached is the file that I can not get to report manifolded (and i've tried about 40 different methods and with more programs than above mentioned). This file doesn't have color, it's just a test.

    I don't think the problem is in my workflow, as said: a simple sphere gives no problems. The stl on which the attached file is based also uploads with no problems. When I analyse the x3d-file in Magics, it analyses identical to the original stl.

    Is there something in the process at Shapeways that analyses my files as non-manifold? Maybe the scalingdifferences between stl and vmrl does the trick? Or maybe ZCorp is more critical when printing color?

    Your help is very much appreciated because I almost can't wait to print something in color!

    Greetings, Eric
     
  6. artur83
    artur83 New Member
    Ok.
    First of, you're right, the x3d and vrml files are considered in meters as units.
    The file you supplied has dimensions of 87 in one of the axis, it's too large.
    but dimension not-withstanding, checking the file in NetFabb reveals a bunch of 'degenrate faces'.
    the default check doesn't fix them, and when analyzing, the mesh appears to be manifold.
    see: http://www.netfabb.com/wiki/Semi-Automatic_Repair_Options
    "Remove degenerate faces", i've adjusted the tolerances to 0.001 for it to get rid of all degen. faces

    however, even after fixing it and uploading, our own MeshMedic still had some issues with it. although it succeeded in fixing and the 3d file preview seems alright.

    We will be looking into this further.
     
  7. EricvanStraaten
    EricvanStraaten New Member
    Hi thanks,

    Could you tell me how in Netfabb you spot the degenarate faces? Attached a screenshot of what Netfabb does at my end.
     

    Attached Files:

  8. GHP
    GHP New Member
    You may need to simplify your model (reduce the number of vertices). My experience with Shapeways suggests that it merges close vertices (based on some absolute distance between them), and since the numbers are smaller when the units are in metres, vertices are more likely to be merged, possibly resulting in a non-manifold mesh. Blender works similarly.
     
  9. EricvanStraaten
    EricvanStraaten New Member
    I've tried to get rid of the degenerate faces in Netfabb. This works like a dream and surely cleanes up the model, but i still get a non-manifold error when I upload a wrl, apparently somewhere in the process some holes are created (see attached).

    What I did is this:

    -remove degenerate faces in netfabb, export as stl
    -import in Magics automatic fixing in Magics (even less faults) - export to stl
    -convert stl to obj in Meshlab
    -import obj in Modo (you want to do that after the fixing because otherwise the UV-maps are thrown away - export to obj, because the x3d exporter in Modo upscales the model, when you downscale the Mesh itself by a factor 1000, this creates additional faults
    -import the obj in Meshlab and export it as wrl, this is accepted by Shapeways, but with a manifold-error.

    Now I'm waiting for the 'manual fixing' by Shapeways and hope this will work.


    Here's some thoughts:

    When I upload a stl, there seems to be no problem whatsoever. I haven't yet ordered someting in sandstone, but in all other materials things are working ok. In all the stl's that I've uploaded so far the degenerates are almost always present.

    So the degenerates are present in my entire workflow, but don't appear as errors in Magics, and also not when I upload an stl (which could also be printed in non-color Sandstone, so why is the file for color so 'unforgiving'?).

    When I upload a x3d or wrl, I get an error. When I sent the service desk the wrl, they find a lot of problems in the file after analyzing it in Magics 14. When I myself extract an stl from the wrl and send that stl to the servicedesk, they find no errors in Magics 14 and even less overlapping triangles than in my own analyse of the file in Magics 13.

    Greetings, Eric
     
  10. EricvanStraaten
    EricvanStraaten New Member
    By the way: The handling of x3d's in Netfabb isn't all that straight forward. When you import a x3d, Netfabb assumes correctly that the 'original size' wasn't in meters, but in mm. However, when you export a 'fixed' x3d, Netfabb converts the mm-numbers to meters, so you end up with a file that is way to big. When you try to scale the model down with a factor 1000 in Netfabb, you create a model that consists solely of these degenerate faces, so this is no solution (thats why I put the obj to wrl conversion in my workflow, I haven't tested if this workflow ends up with a printable colormodel).
     
  11. EricvanStraaten
    EricvanStraaten New Member
    I did a test and reduced the model from 256872 to 59496 triangles. This didn't work and produced a manifold error. Any further simplyfying will destroy the model I think.
     
  12. EricvanStraaten
    EricvanStraaten New Member
    QUESTION: Is there a way to export a correctly scaled fixed .x3d from Netfabb without losing the color?
     
  13. joris
    joris New Member
    I have no idea to be honest, I've never tried. anyone else?
     
  14. deltares
    deltares New Member
    I have exactly the same uses as mentioned above. STL works fine, but I really need the colored sandstone. I've uploaded atleast 200 times a file. And getting quite desperate; especially since there is this important deadline coming up.

    So, did anyone ever solve the issue of having manifold errors just because VRML/X3D works in meters? I've tried things like making the object use, but using a scale factor, hoping that there would be less precision loss, or the opposite.


    When I scale my object 10x bigger (making it too big to print), there is nothing wrong with it... except it's too large.

    I read this is a common issue in the FAQ, surely there is a solution somehow? I've spent so many hours trying to get it right.
     
  15. EricvanStraaten
    EricvanStraaten New Member
    Correction: I've tried to first fix a x3d in Natfabb, apply the correction, then scal it down with a factor 1000 (the model than seems to dissapear and has no scale), uploaded it, and... Shapeways says it's printable! Now for the final test: when you fix a texturized x3d in Netfabb, will the model still have color after that (i would say no, but maybe I'm wrong). Keep you informed....
     
  16. virtox
    virtox Active Member Moderator
    I'd be happy to take a look at problem files today :)
    Just send me a pm or post the file (including textures if applicable) here, and I'll see if I can find anything.
     
  17. deltares
    deltares New Member
    Hi virtox,

    Well, if you are up for a real challenge ;). What kind of format would you want? I'll be spending my weekend on trying to fix this issue, since the deadline is getting me too close. :(
     
  18. EricvanStraaten
    EricvanStraaten New Member
    I did a texture test with Netfabb and even without 'touching' the model and just opening a texturized x3d and than exporting it as x3d, Netfabb 'throws away' the texture (or the UV-maps). So using Netfabb isn't an option after applying textures. I used Netfabb Basic, I don't know about the Professional version).
     
    Last edited: Jun 11, 2010
  19. EricvanStraaten
    EricvanStraaten New Member
    Yes, i think the scaling issue in OBJ-based programs is the only thing that makes things go wrong. When I upload a stl, there's nothing wrong . When I upload a x3d, made in Netfabb by scaling it down a thousand times, everything is ok. But when I use a program that you use to paint your model (and this is the case with Carrara, ZBrush and Modo, to name a few not to exotic names) and try to scale and export as a vmrl, you get a manifold error. Anyone know of a prgram that does this correctly (Maya? Max? Blender? or something else?)
     
  20. EricvanStraaten
    EricvanStraaten New Member
    Just a wild thought: Is there perhaps a way to manually put in another size in the vmrl (since you can open it in a notepad)?