Manifold Problem with this model

Discussion in 'Design and Modeling' started by boraz, Feb 6, 2010.

  1. boraz
    boraz New Member
    Hi guys, I modeled this ring, which I wanna get casted in white gold, it's some sort of a family ring and has my monogram on it.
    I used Rhino, I'm quite the newbie, but the result came out good (I guess). I wanted to 3d print it through Shapeways but I'm stumbling upon the "manifold problem". Can sombody help me with this? I'm really inexperienced, I try to use some tools (Rhino, MeshLab) to fix the mesh but I don't seem to be able to do it.
    Thank you

    Attached Files:

    • 1.stl

      File size:
      16.4 MB
  2. virtox
    virtox Active Member Moderator
    I had a quick look, the model and mesh seem to be alright.
    Seems you are using multiple overlapping shells ?
    This can cause problems with STL,
    If you open the file in meshlab it asks to unify duplicated vertices, if you do this the model becomes non-manifold.
    I think shapeways might do something similar with close vertices from different shells. I don't think STL was meant for multiple shells

    Have you tried opening the file in meshlab (NOT unifying duplicated vertices) and then saving as x3d or other format ?

    Not sure what the size will be, as stl is dimensionless.

    Edit : Nevermind, I tried this myself, didn't seem to work. sorry :(

    Last edited: Feb 7, 2010
  3. Lyndzer
    Lyndzer New Member
    I fixed your file for you. enjoy.

    Attached Files:

    • 2.stl

      File size:
      11.2 MB
  4. boraz
    boraz New Member
    Hey thanks a lot to the both of you.
    Akeno I saw that you fixed the problems, but I noticed the surface of the engraved logo is pretty rough now. Is there anyway to fix the model without losing smoothness and detalis?
    Virtox, I tried to do what you said but it didn't work. I used Minimagics and it showed a lot of errors. I guess they came up when I filleted the letters in Rhino.

    Any other idea befor I start over???

    Thank you
  5. Lyndzer
    Lyndzer New Member
    There's a bit of a dent (tiny) in the edges because of the non-manifold geometry that was happening with it and some edges that in general were bad.

    When you designed the ring it seems like you had mesh's just going in between each other and it caused a lot of problems.. honestly the file will work out fine with you if you get it in WSF and then have it casted, it'll just have to be sanded down a bit (not too much) to get it even.

    If you planned on doing a metal print from shapeways you're going to get those little dents everywhere in the ring anyway since its not 100% perfected for smoothing. If you're sending it off to another company for waxing I can see the problem though but they can probably smooth that area down as a request before it's milled out.

    WSF materially is really solid with sandpaper (I've used it on my models before), also consider the size it's going to be when its printed (ring size) and not blown up 200%.. it's the best I could do though, :<
  6. virtox
    virtox Active Member Moderator
    Never mind my first assumptions :rolleyes:

    I had another look. Not sure what's wrong with the mesh.
    But most software starts crashing when its supposed to be doing something useful with the mesh, so not much progress.
    I got some double faces and such, but most don't make sense.
    Still looks like unintended fusing of fine detail.

    It looks like the whole mesh was created with some sort of subdivision surface ? I guess that's the way rhino works ?

    I understand the need for detail, but in some parts the mesh is way too refined. Perhaps lowering the subdivision count will produce a less problematic mesh ?

    Last edited: Feb 7, 2010
  7. boraz
    boraz New Member
    Ok so I decided I can get rid of the filleted letters, I can live without them.. I guess there will be some natural fillets once the ring is casted. I mean, the edges are not gonna be as sharp as the one I see in the rendering without the fillets.
    So I remodeled the ring without the fillets and I exported a different mesh. now MiniMagic is showing less errors: it's saying there is 1 Inverted Normals and 27 Shells.
    What the heck is a shell? Sorry I don't know what it means.

    Anyway I'll attach the file

    Thanks you guys, you're really nice

    Attached Files:

    • 3.stl

      File size:
      13 MB
  8. virtox
    virtox Active Member Moderator
    Multiple shells means in effect multiple (unconnected) polygon groups.

    Please check out these pages :

    if you wish to learn more on what's going on ;)

    If you want I can check the file for you later (this week)

    Perhaps even add the fillets in proper fashion.
    As this usually gives a smoother result than manually polished sharp edges. Also kinda depends on the effect you want, I guess.

    For the moment I have no time left.

  9. boraz
    boraz New Member
    Virtox, thank you very much for you help!
    If you could check the file for me and even add back the fillet I would really appreciate it. I would like to put the fillets back but I'm not able to do it (I'm sure it can be done, I'm just inexperienced).
    Anyway let me know if you can find the time to help me.
    thanks again
  10. virtox
    virtox Active Member Moderator
    Hmmm :confused The fillet is not really the problem I see.
    Like I said before, the way the mesh is build up is too finely grained for this size, even without the fillet.
    See if you can change that. I have no experience with Rhino so can't help you there. Perhaps something in the export options ?

    Did you try uploading this version ? Might just work, my mesh_check crashes on it ;)
    And adding the fillet to the current mesh wouldn't be very pretty.

    And you can always try again, as practice makes perfect :)