Lost package - no more answers from support

Discussion in 'Customer Service' started by tokka, Jul 3, 2009.

  1. tokka
    tokka New Member
    Hello !

    I ordered 2 Models on the third of May and the package got shipped on the 22th of May.

    I contacted UPS and Shapeways and Joris wrote me that Elena would take care of it.
    In the Meantime UPS called me to tell me that the package got lost somehow. I tried to contact Joris and Elena three times per email. But didn't get any response, yet.

    Today's the 3rd of July, so my question is will I ever get a reprint of the model ???

    btw: Order # is 101948

    -Thorsten
     
  2. joris
    joris New Member
    Thorsten,

    I'm so sorry. We will get to the bottom of your package as soon as we can.

    Joris
     
  3. lelena70
    lelena70 New Member
    Thorsten,

    I am sorry.
    We have been lucking in follow up. UPS is still searching for your package, but after 6 weeks we should have realized they are not going to find it anymore.
    I have entered a production order with refence 4032 to have your models reprinted.
    The models will be shipped to you next week

    Elena
     
  4. tokka
    tokka New Member
    Thanks to both of you !

    It was just terrible to get no response on any email.
    UPS called me about a week after the reporting the package as lost and told me they would notify you...

    Anyhow...glad to hear that my package could finally arrive :)

     
  5. tokka
    tokka New Member
    IT ARRIVED !!!

    Thanks guys/girls ! This time it arrived safely and perfectly looking.
    I will make a few pictures and post it in the "it arrived" section.

    Thanks again.

    -Tokka
     
  6. joris
    joris New Member
    Phew!

    Thats good news!

    Joris