Inverted normals? Where?

Discussion in 'Design and Modeling' started by bradjensen68, Mar 1, 2009.

  1. bradjensen68
    bradjensen68 New Member
    Ok, I am posting my first design to Shapeways (attached) and Joris is telling me that I have inverted normals, however when I run Rhino's CheckMesh, it says:

    This is a good mesh.

    General information about this mesh:
    Mesh does not have any degenerate faces.
    Mesh does not have any zero length edges.
    Mesh does not have any non manifold edges.
    Mesh does not have any naked edges.
    Mesh does not have any duplicate faces.
    Mesh does not have any faces that could make it better if their directions were flipped.
    Mesh does not have any disjoint pieces.
    Mesh does not have any unused vertices.

    ID: 94d44d5b-53d0-48ad-99d3-a2abd859df74 (7)
    Layer name: Default
    Render Material:
    source = from layer
    index = -1
    Attribute UserData:
    UserData ID: B0EE2168-8EC6-42ed-A962-26DEB8CC8F9A
    Plug-in: Rhino Render
    description: Rhino Renderable Object UserData
    saved in file: no
    copy count: 1
    Valid mesh.
    Closed polygon mesh: 3204 vertices, 1068 polygons with normals
    bounding box: (-4.9841,-5.37043,-2.53855) to (4.44205,4.49075,2.3198)

    How do I fix this if my software says there is nothing to fix???

    Attached Files:

    • hex.stl

      File size:
      349.1 KB
  2. daddymack
    daddymack New Member

    Attached Files:

    • hex.DAE

      File size:
      149.9 KB
  3. bradjensen68
    bradjensen68 New Member
    Cool, thanks. Does it only work in DAE? I was trying to upload it directly in STL and then I tried it in VRML and neither worked.

    I will give it a try in DAE. Hopefully, I can get the scaling right because the part that you successfully uploaded is much smaller than was intended.


    -- Brad
  4. bradjensen68
    bradjensen68 New Member
    Heh heh. I figured it out. Wrong units (millimeters instead of inches). :blush:
  5. daddymack
    daddymack New Member
    I use accutrans for final output to .dae usually because you can adjust the final output size when saving.

    There is a tut on how to do the basics in accutrans somewhere in the blog

    Good luck;)
  6. bradjensen68
    bradjensen68 New Member
    Thanks, that is what I did (Accutrans) and it worked out fine, but now I have a new problem. My model is rather big and would cost me over $2000 to print! I think if I hollow it out, I can reduce the price. Since the final product is supposed to be weight bearing, this obviously will only work as a prototype, but at least it will get me one step further. The other option is to build a smaller scale prototype.

    Oh well, back to work on the model....
  7. PeterHermans
    PeterHermans New Member
    I'm having the same problem, Shapeways validation check gives me the message that there are inverted normals. But, according to magics, there aren't any (not even intersecting or overlapping polys).
    Now, my model has some extremely small features (.1mm or even smaller) but I am expecting these to 'wash out' in the printing, that's ok - manually taking out the detail would take forever.
    But I suspect that these small features are picked up by the different tolerances in the Shapeways validator as errors.

    I tried uploading a number of different stl files and I also used accutrans to convert to .dae. All generate the same result.

    I e-mailed Joris already, I hope they can fix the issue (or at least tell me what exactly is wrong with my model).

    Edit: I just did a mini-test and I found out that Magics does not detect non-manifold issue #2; shared edges (as shown here: as an error - it just sees it as two separate shells. Although the validation check should give me a different error than flipped normals it is strange that magics does not detect this.
    Come to think of it, why would this be an issue for printing? So what if it is very thin and might break - if that was the way it was modeled
    Last edited: Mar 2, 2009
  8. ArMOO
    ArMOO New Member
    Hi Peter.

    I think meshlab solves the problems with the double features. Try to open the magics stl in Meshlab ( it will ask you to delete teh doubles ) and save it again as a stl.
    And it will be printable.
    I also have problems with the scaling. I have to figure out how to solve that too. If you know have. I would be happy if you could post it here. I tried also accutrans but it doesn't work always.

    Greetings AO
  9. bradjensen68
    bradjensen68 New Member
    In Accutrans

    Click on Adjust Object Property
    Then choose "Units"
    Choose the appropriate units for "Import Units" and "Export Units"
    Click "Ok"
    Click "Scale"
  10. PeterHermans
    PeterHermans New Member
    I tried it and meshlab does remove vertices (points). Taken it back into magics: no errors. Upload to shapeways: inverted normals error!

    Scaled it 5x as big (so small details might be less of a problem: same error.

    I'm lost on this one. :cry:
  11. daddymack
    daddymack New Member
    Hi AO, feel free to send it to me and I'll run it thru my tests... mack3d at hotmail dot com
  12. ArMOO
    ArMOO New Member
    Hi Daddymack,

    Thanks for offering your help.
    But its Peter who needs a hand. A bit weird because he's using a very sofisticated softwaretool to prepare his files.
    I'm impressed about your proffesional skills as an artist and modeler and offcoarse also you being prepared to help others.
    I showed your work to Didier Francini of Papo in France.
    He's convinced that they way you work its the future in modeling. Feel free to contact him and mention my name ( Arjan Moors ).

    Thanks again. Greetings AO
  13. PeterHermans
    PeterHermans New Member
    Daddymack, I sent you an e-mail :). Thanks for your help. Hope you can figure out what's wrong.